Can't resolve etc/hosts file ... multiclutch issues? Help!

Discussion in 'macOS' started by mdude85, Nov 7, 2011.

  1. mdude85, Nov 7, 2011
    Last edited: Nov 7, 2011

    mdude85 macrumors member

    Joined:
    Jun 26, 2010
    #1
    Hi everyone,

    I am trying to run a program on my Macbook Pro (Lion) and the program would not start up ... I checked the Console log and saw the following message:

    System Preferences: Can't open input server /Library/InputManagers/MultiClutchInputManager.bundle

    I also tried opening up the etc/hosts file with Terminal... I received the same message, then a prompt saying the etc/hosts file cannot be found.

    I have no idea how to proceed from here. I don't even know what Multiclutch is ... I have not installed it on my system. I'd like to just get everything back to normal. I'd at least like to be able to open the etc/hosts file. What's happening to my computer? I tried a reboot to no avail. I haven't installed any programs recently ... I did however update a few programs that I downloaded from the App Store. And I have also recently been having problems accessing some secure websites using Chrome.

    My knowledge of Mac OSX is very limited.... thank you!!
     
  2. yawns macrumors member

    Joined:
    Oct 12, 2011
    #2
    Multiclutch seems to be some 3rd party software that extends multitouch functionality.

    http://osx.iusethis.com/app/multiclutchinputmanager

    It no longer works in Lion

    http://forums.macrumors.com/showthread.php?t=1191406

    When you say you're trying to run a program, do you mean a specific application isn't working (if so, what is it?) or that apps in general crash?

    I would guess one of two things:

    1. The application/s in question require multiclutch and you don't have it.

    2. You had/have multiclutch installed and it's conflicting with the application/s, or causing general errors if you're using Lion.

    This might help:

    http://forums.macrumors.com/showthread.php?t=1193824
     
  3. mdude85 thread starter macrumors member

    Joined:
    Jun 26, 2010
    #3
    Thanks, I've been looking at that thread. Unfortunately my system is not letting me delete the InputManagers folder from the Library. I keeps saying that the directory is not found (and it is also not showing in Finder), even though I know it's there and can also see it when I browse the Library folder using Google Chrome.

    The program I am trying to run is Photoshop. I think it's causing general errors as the etc/hosts file cannot be run unless the bundle is found.

    I didnt even know what MultiClutch was until yesterday ... I never authorized this to be installed on my system, so perhaps it came bundled with something else.
     
  4. yawns macrumors member

    Joined:
    Oct 12, 2011
    #4
    You might not have permissions set on the directory. You could try deleting it from the terminal.

    sudo rm -rf /Library/InputManagers

    Standard disclaimer: Be careful, don't delete stuff you might need, etc..

    If you want to play it safer, skip the above and try this

    sudo chmod -R 777 /Library/InputManagers

    And then you can probably get to it via Finder and move it to the trash.

    Super extra safe approach: Skip all of the above and do the following two commands. Let us know what the output of each before proceeding.

    ls -la /Library | grep -i input
    ls -R /Library/InputManagers
     
  5. mdude85 thread starter macrumors member

    Joined:
    Jun 26, 2010
    #5
    Thanks, I ran the last two lines:

    Output from 1st line
    drwxr-xr-x 2 root wheel 68 Jun 16 19:04 Input Methods
    drwxr-xr-x 2 root wheel 68 Nov 8 02:10 InputManagers

    Ouput from 2nd line
    (nothing)

    However the folder is not showing up in Finder. I've used the Terminal to unhide every system file as well.
     
  6. yawns macrumors member

    Joined:
    Oct 12, 2011
    #6
    The /Library/InputManagers directory is empty, so you can safely delete it. You should be able to do it from your account

    rm -rf /Library/InputManagers

    The error you're receiving is saying that it can't find something in that directory (which really isn't there, anyway). So I'm wondering if deleting this directory alone will solve the problem. If not, you may also need to delete the preference pane for multiclutch. I Googled a bit but am not finding anything about that that might be called (but let's guess it's something with, "multiclutch," in the name...)

    You can check for this from terminal:

    ls -la ~/Library/PreferencePanes
    ls -la /Library/PreferencePanes

    If you see any multiclutch stuff in either directory, delete it.

    You might also want to go through this just to ensure multiclutch is totally gone

    http://forums.macrumors.com/showpost.php?p=11171082&postcount=16
     
  7. mdude85 thread starter macrumors member

    Joined:
    Jun 26, 2010
    #7
    thanks, I've deleted the inputmanager folder using the terminal command but I am still having the issue of opening the etc/hosts file.

    I am trying to open the hosts file using a text editor from terminal but it keeps saying that the hosts file is not found.

    The console message I receive when trying to open the hosts file is

    TextEdit(871) deny file-write-data /System/Library/Caches/com.apple.IntlDataCache.le
     
  8. yawns macrumors member

    Joined:
    Oct 12, 2011
    #8
    Is Photoshop working?

    /etc is a symlink to /private/etc

    Code:
    ls -lha / | grep etc
    Should give you output like this

    Code:
    lrwxr-xr-x@  1 root  wheel    11B Oct 23 00:24 etc -> private/etc
    If that looks good,

    Code:
    ls -lha /private/etc/ | grep host
    Outputs

    Code:
    -rw-r--r--   1 root  wheel    87B Oct 23 00:24 hostconfig
    -rw-r--r--   1 root  wheel   236B Oct 23 00:24 hosts
    -rw-r--r--   1 root  wheel     0B Aug 16 21:40 hosts.equiv
    And

    Code:
    cat /private/etc/hosts
    Outputs

    Code:
    ##
    # Host Database
    #
    # localhost is used to configure the loopback interface
    # when the system is booting.  Do not change this entry.
    ##
    127.0.0.1	localhost
    255.255.255.255	broadcasthost
    ::1             localhost 
    fe80::1%lo0	localhost
    So, does any of that not work or look different for you?
     
  9. mdude85, Nov 8, 2011
    Last edited: Nov 8, 2011

    mdude85 thread starter macrumors member

    Joined:
    Jun 26, 2010
    #9
    Nope it is not working.

    I ran ls -lha /private/etc/ | grep host. the output is:

    -rw-r--r-- 1 root wheel 87B Jul 22 14:29 hostconfig
    -rw-r--r--@ 1 root wheel 740B Oct 13 01:19 hosts.backup
    -rw-r--r-- 1 root wheel 0B Jun 18 15:44 hosts.equiv
    -rw-r--r--@ 1 [name] staff 742B Oct 13 01:22 hosts.txt
    -rw-r--r-- 1 root wheel 740B Oct 13 01:19 hosts.umbrella
    -rw-r--r-- 1 root wheel 236B Jul 22 14:29 hosts~orig

    Alas... I don't see just "hosts".

    I ran cat /private/etc/hosts. It says "no such file or directory."

    As I recall, I installed Tor Browser/Vidalia and had to edit the hosts file. It asked me to create a backup, which I did. It seems somehow the hosts file got deleted (even though I've been using Tor for a while now and this issue just cropped up a few days ago) so I would guess my best option is to change the backup file to the original file? Can I do this with the finder? I'm just not that comfortable with the Terminal.

    Thanks for holding my hand thru this.
     
  10. yawns macrumors member

    Joined:
    Oct 12, 2011
    #10
    you could create a copy with Finder, just make sure the contents are correct. You can also create a blank file by doing

    touch /private/etc/hosts

    in the terminal. Then open it with whatever, copy/paste the default values (as in my post above), and edit from there.

    Edit: Ah, I didn't see the connection between these two before. You're trying to edit the hosts file to prevent Photoshop from phoning home, right? I don't think that will prevent the crashing, if that's still happening. If you haven't done so, run through the, "completely uninstall..." stuff above to be sure multiclutch is gone. I just found out there's a fork of multiclutch called, "BetterTouchTool," to watch out for as well :\
     
  11. mdude85, Nov 8, 2011
    Last edited: Nov 8, 2011

    mdude85 thread starter macrumors member

    Joined:
    Jun 26, 2010
    #11
    Thanks, I think Multiclutch is gone for good. I'm not sure what values were in the hosts file so I think my best bet is to just copy and rename the .backup file to the actual hosts file as the backup was created not long ago. However I still want to keep the backup file just in case the original hosts file gets deleted again. I want to see if I can get the contents of the backup file back into the original hosts file.

    In order to do this I opened /private/etc in Finder, copied the hosts.backup file to the Desktop, renamed it hosts (no extension) and repasted it into /private/etc in Finder. I then flushed the DNS cache.

    However when I try to open the file in Terminal using a text editor, the file appears to open, then quickly closes and I receive the following message:

    2011-11-08 14:40:00.713 TextEdit[1163:10d0f] NSTrackPersistentURLs: LSSharedFileListInsertItemURL() failed at inserting URL file://localhost/etc/hosts (/etc/hosts)

    I also receive the following message in console:

    TextEdit(1163) deny file-write-data /private/etc/hosts
     
  12. yawns macrumors member

    Joined:
    Oct 12, 2011
    #12
    I think it's saying you don't have write permissions to the file. Back on the terminal:

    sudo nano /private/etc/hosts

    Edit as usual. Hit control+x to exit, Y to save.
     
  13. mdude85 thread starter macrumors member

    Joined:
    Jun 26, 2010
    #13
    Thanks, that seems to work, but I still get the error whenever I try to open in a text editor. I am using the command


    sudo /Applications/TextEdit.app/Contents/MacOS/TextEdit /etc/hosts
     
  14. yawns macrumors member

    Joined:
    Oct 12, 2011
    #14
    I don't know how to edit it in TextEdit as root, sorry.

    sudo -b open -e /private/etc/hosts

    is supposed to work, but it's still, "locked," when I do it here under Lion. Maybe the annoying "versions," is getting in the way.
     
  15. mdude85 thread starter macrumors member

    Joined:
    Jun 26, 2010
    #15
    That's fine, I can just edit in the terminal.

    thank you so much for your help.. do you know what might have caused the host file to be deleted? is this a common occurrence?
     
  16. yawns macrumors member

    Joined:
    Oct 12, 2011

Share This Page