Can't restore backup image of Win 7 partition, please help

Discussion in 'Windows, Linux & Others on the Mac' started by trayan, Jun 11, 2016.

  1. trayan macrumors newbie

    Joined:
    Jun 10, 2016
    #1
    Hi everyone, I've literally spent 2 whole days trying to resolve this and getting desperate. Would really appreciate any advice.

    I have a Macbook Air with a Win 7 Bootcamp partition. I backed-up images of the Win 7 partition using 2 different software to be safe - Aomei and Macrium.

    After getting my SSD replaced (same capacity), I reinstalled Win 7 using Bootcamp. Then I booted into the Windows PE recovery environment of each backup software but ran into different problems.

    Aomei:
    - I tried replacing the current Bootcamp partition with my backup image, but it kept failing because the "partition tables were locked". I thought this might be due to Bootcamp, so I uninstalled Win 7 using Bootcamp; used Mac Disk Utility to create a new partition; formatted the partition into NTFS with another tool; tried to restore my backup image into the new partition, but again the "partition tables were locked".
    - So I formatted the entire disk drive and removed OS X. This time I could finally restore my backup image onto the disk, but it wouldn't boot even after setting it as the active boot drive.
    - I suspect this is because my backup Win 7 image was taken as a Bootcamp partition, so it wouldn't boot as an independent Windows installation.

    Macrium:
    - I overwrote the new Bootcamp partition with the backup image file (didn't show any "partition tables locked" issue with Macrium). However, it would not boot. However, because Bootcamp still works with Macrium and my Windows partition is set as a the default boot disk, the Windows start-up assistant was able to run automatically, but couldn't fix the problem.
    - I went back into the Recovery Environment and used the Macrium Boot Recovery tool, but it wouldn't detect the C:/Windows path. Finding this strange, I used a disk explorer tool and it seems like C: was still taken up by the fresh Win 7 installation, rather than my backup which was supposedly restored onto the drive. Yet, if it was true that my recovery failed, then the fresh Win 7 installation should have booted normally rather fail? I really don't know what's going on.
    - So I used both the Aomei and Macrium Recovery environment to examine the partitions, and it's actually showing the correct partition/disk usage as per my recovery image (and not the fresh win 7 installation).

    Please help I really don't know what else to do. I've made the horrible mistake of not backing up my Bootcamp partition with a Mac-based tool instead. But at least I have my backup in two different image format. .adi (Aomei) and .mrimg (Macrium). Is there any way I could extract the files in the image and re-backup using a Mac-based tool that will make recovery through Bootcamp easier?

    Thanks so much.
    --- Post Merged, Jun 11, 2016 ---
    Update:
    I've looked at the Macrium recovered disk through OS X, and can confirm that the files in there are the backed-up files, rather than the fresh Win 7 installation. So that's a relief. Any idea how I get it to boot correctly, or if I back-up the partition through Mac now and restore it from a Mac environment, will that help? I'm thinking not because the Boot process is somehow corrupted and backing it up as it is will just capture all the same problems? Thanks
     
  2. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #2
    Do you still have the old SSD? Winclone is the only software that I've seen successfully backing up and restoring a Bootcamp partition. Wish I had more for you.
     

Share This Page