can't restore customised 2.1 with iTunes 8

Discussion in 'Jailbreaks and iOS Hacks' started by bobdobbs, Sep 23, 2008.

  1. bobdobbs macrumors newbie

    Joined:
    Jul 20, 2008
    #1
    Hi guys.

    I managed to update a couple of 2G iphones to 2.1 using Pwnagetool (blessed be)
    and iTunes 7 on my mac.

    At some point after that, I installed iTunes 8.

    A friend accidently updgraded his 2G to 2.1 and asked for some help. I figured that I could install the customised firmware on his as well.

    So, I put his iPhone into DFU mode, connected it to the mac and proceeded.
    iTunes saw the iPhone, and began the process.
    Then it gave me an error 1600!

    Arrgh!

    I have tried rebooting the iphone, taking it in and out of DFU, rebooting the computer, all without success.

    I'm trying to
    a) figure out why I can't put the custom firmware on this iPhone,

    b) figure out how to actually get the firmware on the iPhone.

    Any advice appreciated.

    Thanks.
     
  2. ntrigue macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #2
    I would hold home while plugging in and through the restore process and get back to us. This 1600 is often solved with different USB/Port/Computer
     
  3. bobdobbs thread starter macrumors newbie

    Joined:
    Jul 20, 2008
    #3
    Hi ntrigue.

    I've done a bit of homework, and I think I might know what the problem is.

    First I tried your suggestion. I checked the cables, rebooted, put the iphone into restore mode and tried a restore to a customised firmware.
    That yielded a fail with a 1600 error.

    I then killed the ituneshelper process, killed itunes and restarted it. Then, with the iphone in restore mode I tried restoring to a normal 1.1.4.

    This failed with an error 20.

    Anyway, after a little googling I believe that the new DFU mode in 2.1 will not accept customised firmwares. This could be part of the problem.

    Any more suggestions anybody?
    I'm getting a bit worried about my mates iphone now.
     
  4. Roessnakhan macrumors 68040

    Roessnakhan

    Joined:
    Sep 16, 2007
    Location:
    ABQ
    #4
    I got the 1600 error a few times when trying to load a custom firmware. It worked eventually. I'd suggest just keep trying until you get lucky. You have seemed to try quite a bit already. Try rebuilding the firmware.
     
  5. /b/ macrumors member

    Joined:
    Sep 1, 2008
    #5
    You can't install custom firmware if the iPhone isn't jailbroken I believe.
     
  6. bobdobbs thread starter macrumors newbie

    Joined:
    Jul 20, 2008
    #6
    Care to explain further?
    Do you mean I have to jailbreak the iphone first, and then re-install the custom firmware ?

    I haven't found any information anywhere on how to jailbreak a locked 2.1 iphone.
     
  7. bobdobbs thread starter macrumors newbie

    Joined:
    Jul 20, 2008
    #7
    Guys.

    I haven't found a way to do it yet.

    As per suggestion, I've tried over a dozen times.
    I haven't had any luck.

    I also tried plugging the phone into my PC and restoring the custom firmware - both in restore mode and DFU mode.
    Both attempts failed.

    I don't think the iphone is damaged, 'cos it will still jump in and out of DFU if I want it to.

    My next step is to downgade iTunes on my Mac, to 7.6.
    I will uninstall 8, dig out all of the old itunes stuff from the system that it leaves behind, then I'll start again.

    But if anyone else has any helpful info, I'm, all ears.

    Thanks
     
  8. PYR0M310N macrumors 6502a

    PYR0M310N

    Joined:
    Aug 29, 2006
    #8
    Why do you want to put a custom firmware on there? Why don't you just use quickpwn?
     
  9. bobdobbs thread starter macrumors newbie

    Joined:
    Jul 20, 2008
    #9
    I would like the iphone unlocked and jailbroken.
    Or, unlocked at least.

    Is this what quickpen does ?
     
  10. bobdobbs thread starter macrumors newbie

    Joined:
    Jul 20, 2008
    #10
    I just did some reading on quickpwn over at the dev-team's blog.
    It seems that quickpwn does not unlock iphones. Just jailbreaks them.
    And it does not support the 2.1 firmware.

    So I don't think that quickpwn will be of any use to me.

    Any more ideas?

    Is this happening to anyone else ?

    [edit]

    I spoke too soon.
    I've found a guide over at iclarified that shows how to unlock and jailbreak a 2G iphone running 2.1 on windows.
    I'm gonna go through it and see if it works.
     
  11. bobdobbs thread starter macrumors newbie

    Joined:
    Jul 20, 2008
    #11
    Oh Frabjous day!

    Quickpwn!

    Success - using quickpwn on windows.
     
  12. powaking macrumors 6502

    powaking

    Joined:
    Jul 3, 2008
    #12
    Newest Quickpwn supports 2.1 but still does not unlock the phone.
     

Share This Page