Can't restore iPhone iOS 4.2.1 ! Help please !

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sPwism, Jan 17, 2011.

  1. sPwism macrumors newbie

    Joined:
    Jan 17, 2011
    #1
    I recently purchase my iPhone4 and jailbreaked it with RedSnow.

    It appears that my camera flash light is faulty now as it wont turn on when i use my camera or any flashlight apps. I believe it's a software fault as i did not drop my phone and have been very gentle with it.
    I have tried to reset the settings but the flash light still does not work.
    I need to restore my phone back to factory state so that i can send it back for a warranty exchange.

    However when i tried to restore with the iTunes, after verification with apple,error code " Your iPhone could not be restored, this device isn't eligible for the requested build 4.2.1 "

    Would appreciate if i receive help and tips on this issue.
    Thanks !
     
  2. yayitsezekiel macrumors 6502a

    yayitsezekiel

    Joined:
    Aug 1, 2008
    Location:
    Irvine, CA
    #2
    have you tried putting your iPhone in DFU mode before restoring?
     
  3. sPwism thread starter macrumors newbie

    Joined:
    Jan 17, 2011
    #3
    Oh, DFU mode ? how do i put my iPhone into DFU mode ?
     
  4. sPwism thread starter macrumors newbie

    Joined:
    Jan 17, 2011
    #4
    Oh ok i managed to get it into DFU mode and it worked ! thanks !
     
  5. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #5
    Interesting...the other thread I responded to in this forum had the same issue, also with an iPhone 4. I wonder if Apple's update servers are just being wonky...

    -- Nathan
     

Share This Page