Can't restore my jailbroken iphone 4, please help. Im desperate

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Trenton92, Dec 2, 2010.

  1. Trenton92, Dec 2, 2010
    Last edited by a moderator: Dec 3, 2010

    Trenton92 macrumors newbie

    Dec 2, 2010
    Ok, so today while at the store, I dropped my iphone and the back glass shattered. ****. So I look it up and apperently its only like $30 to replace. The thing is that my iphone was jailbroken and I didnt want to take it to the apple store like that. So I plug it up to my computer and hit restore. I was running 4.1 on it but my computer prompted me to update to 4.2, so I did.

    The problem comes in, when the damn thing froze at about 2/3 of the way through the loading bar and stuck there for at least 2 hours. I took it out, changed USBs and tried again. No luck. Now all I have is an iphone that is telling me to hook it up to itunes and it wont do anything when I do that.

    Please someone help me, my life is on this phone and I can't take it to apple. If you know of anything to help, I'd be soo grateful. Please guys, be pals to me.

    I also tried putting it in DFU mode but this didnt seem to do anything special except turn the screen dark.
  2. lucifiel macrumors 6502a


    Nov 7, 2009
    In your basement
    Does the phone appear in itunes at all?

    And don't bump your own thread. Against forum rules.
  3. PsstGreek macrumors 68040


    Oct 21, 2010
    Tampa Bay
    Have you tried restoring your iPhone on another computer?
  4. eastercat macrumors 68040


    Mar 3, 2008
    FYI: if you bring your phone into the apple store, they won't fix it; they'll tell you to pay for a replacement (likely refurbished) phone.
    Your screen is supposed to go black when you put it in DFU. iTunes is supposed to recognize your phone when it's in DFU. It'll say something like phone detected in recovery mode or something similar. However, I own a mac and don't know if it's the same on a windows PC (assuming you own one).
  5. ziminimi macrumors newbie

    Dec 12, 2010


    I have the same proble, i'm stucked in DFU mode and I can't restore my iphone 4. I even tried pwnage tool and ireb, but nothing.

    have you resolvd your problem? if so can you share plase?
  6. mikelegacy macrumors 65816


    Dec 5, 2010
    Pittsburgh, PA
    You can download TinyUmbrella and click "Kick out of Recovery Mode" it should reboot as normal.
  7. Jhoo macrumors newbie

    Apr 10, 2011
    Can't restore to factory settings

    Hi all:

    Wondering if someone could help me out. I've jailbroken my iPhone 4 using greenpois0n. This was done on firmware 4.2.1. I used TinyUmbrella to save my SHSH. I tried doing a restore to 4.2.1 today and I get about 60% of the way through before it just stops and sits idle. iTunes indicates that the process is nearly through while the status bar on my phone is at about 60%. I've searched plenty of forums and cannot seem to find a fix for this. Is there something I'm missing? Do I need to do something with TinyUmbrella before restoring? Also, I should mention that I edited the hosts file so it should be fine.

    I'd like to be able to update to 4.3.1 in order to use redsn0w, though at this point I'd be happy just to get my phone working again.

    Any help would be greatly appreciated! Thanks everyone for taking the time to read this.

Share This Page