Can't restore single partition

Discussion in 'macOS' started by NightLord, Jun 13, 2008.

  1. NightLord macrumors regular

    Joined:
    Dec 25, 2005
    #1
    I had ubuntu installed on my macbook but wanted to get my single os x partition back, so I used Gparted off of a linux boot CD to delete the linux partitions and replace it with a single non formatted one. I then tried to use boot camp to restore it to one partition, but it just kept running without finishing, I left it for over an hour, before closing it with Cmd+Q.

    So I tried using disk utility to delete the unformatted partition and resizing the hfs one. Although I can delete the unformatted partition, when I try to resize the hfs one, I get an error that says "Partition failed with the error: MediaKit reports partition (map) too small."

    Any idea what I need to do to fix this?

    Btw, I'm using Leopard 10.5.3
     
  2. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    Your partition map is probably messed up. This can happen on occasion when using certain partitioning software. GParted, Partition Magic, BING, etc. Anyway, what I suggest is first make a bootable clone of your OS X partition to an external hard drive using something like SuperDuper or Carbon Copy Cloner. Then boot with your Leopard disk and wipe the internal drive. Partition it and format it for OS X, and install OS X. Boot from the external HD, and clone back to your internal drive. Some work involved but you should be back up to speed.

    BTW, Carbon Copy Cloner is donation-ware, whereas SuperDuper is shareware.

    Regards.
     
  3. NightLord thread starter macrumors regular

    Joined:
    Dec 25, 2005
    #3
    Cheers for the advice mate, but when you mentioned that my partition map might be buggered, I just rebooted and when rEFIt came up, I just used its partition map repair tool. When I booted back into OS X, it restored my partition without a problem :D

    Thanks for reminding me of an option which I feel pretty stupid for overlooking :)
     

Share This Page