can't restore to/install any firmware

Discussion in 'iPhone Tips, Help and Troubleshooting' started by omr, Jul 19, 2012.

  1. omr macrumors member

    omr

    Joined:
    Jun 27, 2012
    Location:
    Las Vegas, NV
    #1
    My iphone 3gs randomly went into recovery mode (logo loop) during normal operation. I've tried all the usual troubleshooting variations with regard to restoring the device via itunes, i.e. updating itunes, swapping cables and inputs, trying both macbook pro and pc, trying on my primary itunes with backups and on a clean itunes (no account/backups), on WiFi and direct Ethernet cable. All attempts result in "The iPhone "iPhone" could not be restored. An unknown error occurred (1)."

    I went to a local Apple store, but all they did was the normal restore process via itunes, got the same error, and told me to buy a new phone.

    I tried using iRecovery to boot it out of recovery mode/logo loop to see if that would solve anything. I got iRecovery to boot it, but the iPhone then just rebooted itself back into recovery mode.

    I then put my iphone into DFU mode and attempted to direct itunes to install various firmwares via hold option/alt + click on "restore." I acquired/downloaded the various 3gs firmwares from here: http://www.felixbruns.de/iPod/firmware/
    All attempts result in: "The iPhone "iphone" could not be restored. This device isn't eligible for the requested build."

    I get the furthest in the restore process by allowing itunes to choose the firmware, i.e. iOS 5, but still get the "...unknown error (1)."

    My iphone was never jailbroken, and was running iOS 5 as well as a 3gs could be expected, prior to the random "crash" into recovery mode.

    I'm wondering if attempting a jailbreak and installing a custom firmware is a worthwhile endeavor? Or if anyone has any other options I'm all "ears."
    I'd still like to be able to at least use it for some function, like an ipod and/or usb thumb drive. Otherwise I'll look into selling it for parts.

    Thanks in advance
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    Make sure you are using the latest version of iTunes and the latest version of iOS. Try changing which USB port you use, restart the computer, and try a different computer. If none of that works, put it into DFU mode (Google it) and restore it. If it still isn't working, you likely have a hardware problem.
     
  3. omr thread starter macrumors member

    omr

    Joined:
    Jun 27, 2012
    Location:
    Las Vegas, NV
    #3
    Um thanks...? ;)
    See op post
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    It's best to double check everything before deducting it to be a hardware error, which it sounds like it is. Guess you'll be having to buy a new iPhone.
     
  5. omr thread starter macrumors member

    omr

    Joined:
    Jun 27, 2012
    Location:
    Las Vegas, NV
    #5
    Yes, I agree, but that's why I listed that I had double checked everything. Been trying since Monday

    Unless it can grab a custom firmware it's done as far as what I can do with it
     
  6. noiceT macrumors 6502a

    Joined:
    Jul 7, 2008
    Location:
    Catalina Wine Mixer
    #6
    Do a custom fw. Better than having it non-functional. You'll also get more if you try to sell it, rather than just for parts.
     
  7. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #7
    Download 5.1.1 Ipsw

    With redsnow make a custom NO_BB ipsw, put phone in DFU and do a ALT-restore in iTunes.

    Do you have the iPad BB installed?
     
  8. omr, Jul 20, 2012
    Last edited: Jul 20, 2012

    omr thread starter macrumors member

    omr

    Joined:
    Jun 27, 2012
    Location:
    Las Vegas, NV
    #8
    okay thanks. I'll start learning how to do this. I've never attempted jailbreaking but that's my only option at this point.
    I don't have the ipad baseband installed, and I'll download that, the 5.1.1 ipsw and redsnow and figure out hot create the custom firmware?


    any guides you think are helpful would be appreciated.
    thanks again
     
  9. omr thread starter macrumors member

    omr

    Joined:
    Jun 27, 2012
    Location:
    Las Vegas, NV
    #9


    I created a custom firmware via redsnow for iOS 5.1.1 (no BB), and installed via redsnow's Pwned DFU mode (identified/verified ios 5.1.1) and option/alt + click restore in iTunes to the new custom firmware (no BB).
    I got that to install on my iPhone. However, from that point it would not sync or restore from/to backup, nor could it pick up any network signals. WiFi, Bluetooth were greyed out, and no network info. (modem or baseband was blank).
    I wasn't able to restore a stock apple firmware via itunes (regular restore) either.
    I then proceeded to jailbreak via redsnow (5.1.1 untethered).
    No change in network availability.
    I read that my 3gs bootrom (new) was still within the compatibility range to upgrade/flash ipad baseband 6.15 without 'bricking" it. Via redsn0w jailbreak I updated BB (to ipad BB).
    Still no change in network status.
    I then read that you needed to downgrade from 6.15 to 5.13.04 in order for ultrasn0w to be able to unlock, and I figured might as well try unlocking to see if that gives me network access.
    Did the BB downgrade via redsn0w, however I can't tell which if any baseband is installed because this is still blank in the iphone settings.
    Still no network status change.
    Downloaded DiskAid and the latest ultrasn0w .deb file, and proceed to created the cydia autoinstall directory via diskaid as instructed.
    Rebooted a couple times, no network status change i.e. still greyed out and baseband/modem blank.
    I then opened diskaid to verify the directory and .deb file was on the iphone, and the directory appears, but despite repeated attempts, the .deb file never appears to be there. I haven't figured out if that's normal.

    At this point I can't confirm I even have ultrasn0w installed on the phone, nor whether any baseband flashes ever worked.
    Additionally, the iphone is randomly rebooting periodically.
    I'll start from scratch, reinstalling the custom firmware, jailbreaking, flashing the ipad baseband (which I also read that ultrasn0w can unlock it at 6.15 as opposed to being downgraded to an "unlockable" 5.13.04), and then try to install ultrasn0w offline again via diskaid (since without any network access I can't do it via Cydia).
    after all of this time and effort, I'm thinking there really is a hardware issue though... f*&%
     
  10. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #10
    Just install ultrasn0w in cydia.

    Download Tinyumbrella, connect phone,
    Open TU

    On the main page it should gave you the info on the phone, it will give current BB as well.
     
  11. omr thread starter macrumors member

    omr

    Joined:
    Jun 27, 2012
    Location:
    Las Vegas, NV
    #11
    I'll try Tiny Umbrella, it'd be interesting if it sees something, but currently I can't install via cydia because I have no network connection: cellular, bluetooth, or wifi... :(
     

Share This Page