Can't "Save As..." in Pages after Sierra update

Discussion in 'macOS Sierra (10.12)' started by zamboknee, May 16, 2017.

  1. zamboknee macrumors regular

    Joined:
    Aug 10, 2009
    #1
    I"m using Pages 4.3 but since upgrading to Sierra I'm not able to 'Save As...' a new file. It just saves as is so I have a file saved as 'untitled.'
    I'm curious as to why this is happening.
    Haven't noticed any other apps behaving this way (OmniOutliner 5). Is it because this version of Pages is older?
     
  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    annoying right? try Duplicate, then you can name it, save it as a separate file...
     
  3. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #3
    If you hold down the option key -before- you try the "file" menu, do you get "save as…"?
     
  4. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #4
    ha! good call, did not know about that... and it works...
     
  5. zamboknee thread starter macrumors regular

    Joined:
    Aug 10, 2009
    #5
    works for me too. Is this a change in Sierra? If so, why would other applications still default to 'Save as...?'
     
  6. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #6
    You can add the command "Save As" back to all apps.

    Open System Preferences > Keyboard > Shortcuts
    Select App Shortcuts
    Select All Applications dropdown
    Select +
    Type exactly Save As… (Note that the three dots are a single ellipsis character, which you can type with Option-semicolon. )
    Enter the short cut by typing command shift uparrow.
    You'll find the command available in all apps now.
     
  7. mailbuoy macrumors member

    mailbuoy

    Joined:
    Jan 16, 2014
    Location:
    Davidsonville, MD
    #7
    Excellent tip! Thank you!
     
  8. interstella macrumors regular

    interstella

    Joined:
    Sep 29, 2013
    Location:
    Suffolk, England
    #8
    1000 likes for dianeoforegon. Thanks for a great tip!
     
  9. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #9
    Glad I could help. You can use this to add shortcuts to other Finder items in the Menu bar that do not have shortcuts. Be careful when adding a shortcut to add one that is not already used. I usually add Command, Option, Control plus another key.
     
  10. zamboknee thread starter macrumors regular

    Joined:
    Aug 10, 2009
    #10
    Thanks a ton.
    Pages is defaulting to the Pages iCloud for saving though. How do I change THAT?
     
  11. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #11
    You can uncheck Pages in System Preferences > iCloud. You would still have the option to save to iCloud, just not to the special Pages folder created by Apple.

    Pages for Mac: Save and name a Pages document
    https://support.apple.com/kb/PH23713

    Default Folder X allows you to set the default folder on a per-application basis, or system-wide.

    Try the demo.

    http://www.stclairsoft.com/DefaultFolderX/
     

Share This Page