Can't see any Files on iMac

Discussion in 'MacBook Air' started by meagain, May 10, 2008.

  1. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #1
    Just bought an MBA today and am having zero luck wirelessly seeing the files, videos, etc. on my iMac for viewing on the MBA. In my iMac, the sharing options are all checked right. But I cannot get access to it other than something called a "drop box". Same the other way around.

    Can anyone share in what way I am being stupid? Thank you.
     
  2. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #2
    Navigate to the other computer in Finder and in the upper right corner of the window, click "Connect As..." and enter your username and password for the other computer.
     
  3. FJ218700 macrumors 68000

    FJ218700

    Joined:
    Mar 8, 2007
    Location:
    Blue Dot, Red State
    #3
    how are you trying to connect?

    see if the command-K route works
     
  4. mackindergarten macrumors 6502

    Joined:
    Feb 21, 2008
    #4
    Hi,

    you need to share folders on the iMac (bring up Get Info on a folder/file and checked Shared and set users)

    On the MBA be sure to click Connect As…

    Hope this helps.
    /Rupert
     
  5. juro macrumors member

    Joined:
    Nov 11, 2007
    #5
    It's simple, really.

    Let's say you're on your Air and want to see the files on your iMac - on the finder on your Air, click on the name of your iMac on the left side of the pane.
    On the main Finder window, on the upper left side you will see a button labeled "connect as". Click on that and in the succeeding prompt that opens, simply log in as you would log in to your iMac.

    That should give you full access to your iMac.

    Same thing goes when you want to access your Air from your iMac. From your iMac you "connect as" with your Air log in details.

    EDIT: Yeah, to what the post above mine says. Must have been typing the same time.
     
  6. meagain thread starter macrumors 68030

    Joined:
    Nov 18, 2006
    #6
    I'm trying to see my iMac's files/vids from the Air via the Air's Finder. When I hit "connect as" from either the air to view the imac or the imac to view the air, it doesn't accept my user name/ID for either. This is puzzling.

    I can see our NAS and my husband's computer from my iMac just fine without checking "connect as"

    EDIT: Juro - I'll try that.
     
  7. meagain thread starter macrumors 68030

    Joined:
    Nov 18, 2006
    #7
    OK - I was doing the logins ass-backwards.

    Now is there a way to avoid this "connect as" login business to get easier access?
     
  8. wordy macrumors regular

    wordy

    Joined:
    Feb 26, 2008
    Location:
    Toronto
    #8
    Check your keychain and if there are any saved passwords for the iMac share, delete it then proceed as above.

    I guess it also goes without saying that you check your l/p and caplock keys too. ;)
     
  9. mackindergarten macrumors 6502

    Joined:
    Feb 21, 2008
    #9
    I'm not entirely sure what you mean. You can check Remember this password in my keychain as you connect to your iMac.

    Doing so should show you the shared folders right away, when you click the iMac in the Sidebar in the future.

    /Rupert
     
  10. meagain thread starter macrumors 68030

    Joined:
    Nov 18, 2006
    #10
    I'm able to connect as "guest" with everything but to the Air..
    But now I'm able to as you say - see the Air from the iMac without "connect as". It takes a LONG time for the Air's guts to show up. Annoying.

    Clearly something is set up wrong with the Air to where other computers need to log in and/or wait a while for the contents to show up. Same with my Air. On the Air, I can instantly see the other computers but my iMac needs the "connect as" and a login. IDK what settings to change to avoid that.
     
  11. wordy macrumors regular

    wordy

    Joined:
    Feb 26, 2008
    Location:
    Toronto
    #11
    You should delete any keychain entries for the Air on the iMac, and then in the finder sidebar if you can see the Air, you should click on it, then "connect as" and make sure after you type in your L/P that you click the "save to my keychain" option.

    If you mean that you have to connect every time, on the iMac, in Finder preference, check off the "connected servers" box (see screenshot). Somehow mounting it enables much quicker access to the server's contents than going through Finder's sidebar.
     

    Attached Files:

Share This Page