Can't See External Drive In Finder

Discussion in 'Mac Basics and Help' started by DJS1138, Jun 16, 2012.

  1. DJS1138 macrumors newbie

    Jun 16, 2012
    New to Mac, intermediate PC user. I'm having an issue where I can't see my Seagate Free Agent in my 2011 MacBook Pro (10.7.4).

    The drive is NTFS but I'm using Paragon and can write to it, up until last night I had no problems. I use it to Dj and the place I was at last night had two power issues (someone cut the power not realizing it) and I got the "drive did not eject" message. Tonight when I tried to plug in my drive it wasn't recognized in my finder. I thought it could have something to do with the power issues last night and here's what I did in terms of troubleshooting.

    Plugged the drive into my PC, ran an error check, everything was fine. I was directed to this forum through Google and read about resetting SMC, did that, no luck. I also read about resetting the PRAM and another user who had an issue with a drive, cleared the cache and everything worked. I tried those as well with no luck.

    I then plugged in my brothers identical model drive to see what would happen and sure enough I don't see it in the finder.

    I do see it in system report when I go to USB, this is what puzzles me. I'm usually pretty good at troubleshooting but I'm about 2 weeks into owning a Mac and the last time I had used Macs regularly was in school a few years back on G4s, I'm a little out of my element.

    This is the model of drive

    I hope I've included enough info, any help would be appreciated.
  2. Roxxy macrumors newbie

    Nov 5, 2012
    Similar Issue

    I had a similar issue with my WD 1 TB external hard drive. While emptying the trash with my HDD connected the power was interrupted and now it isn't recognized under Finder. I can see it under my System Profiler and DU. I have all my pictures and music on this drive so reformatting it is NOT an option. Any suggestions out there????
  3. MacTinker macrumors newbie

    Nov 9, 2012
    Hopefully it is this simple.

    Check you preferences in Finder and make sure that you have the External hard drives ticked in the Sidebar menu.

    ~~Love Macs cause they work..... and if they don't you can tinker until they do.~~
  4. Pakaku macrumors 68020


    Aug 29, 2009

Share This Page