Can't See Photos on my Back Up Hard Drive

Discussion in 'MacBook Pro' started by Winsors1, May 25, 2008.

  1. Winsors1 macrumors newbie

    Joined:
    May 21, 2008
    Location:
    Pickens, SC
    #1
    I back up my Mac to a 500gig external HD. My problem is when I open Time Machine, open the most recent [or any for that matter] Back Up folder, when I try to open iPhoto I get an error code "10657" and iPhoto doesn't open. Does anyone know what a "10657" Error code is?
     
  2. killerwhack macrumors regular

    killerwhack

    Joined:
    Aug 5, 2004
    Location:
    Los Angeles, California
    #2
    Solution from an apple forum posting

    I am pasting this from an apple forum.

    Make sure you replace "username" with your own username.

    ------------------------------------
    i had this problem for awhile, the fix was a terminal command, let me find it. here this worked for me. type in terminal

    sudo chown -R username:username ~/Pictures

    you can also make sure your permissions are correct
    ------------------------------------
     
  3. aarond12 macrumors 65816

    aarond12

    Joined:
    May 20, 2002
    Location:
    Dallas, TX USA
    #3
    Updated fix

    The CHOWN statement has a problem with the parameters. I also noticed after fixing the permissions of the Pictures folder and subfolders (was "700", now "755"), I was still experiencing the iPhoto launch problem.

    My solution, after noticing that I could go to Terminal and launch the application from /Applications/iPhoto.app/Contents/Mac OS/iPhoto, was that ownership of the files in the application was not correct.

    My fix:

    Bring up the Get Info on the iPhoto application in the Applications folder and manually add myself as a user. (I guess you could also add "Everyone".) This solved the issue to me.

    Caveat: Launching iPhoto from the old icon on the Dock still returned the error! :confused: I had to launch the application from the Applications folder, then use the Keep In Dock function and trashed the old iPhoto icon.

    -Aaron-
     

Share This Page