Cant seem to restore iPad 2.

Discussion in 'iPad Hacks' started by kdesign7, Jul 6, 2011.

  1. kdesign7, Jul 6, 2011
    Last edited: Jul 6, 2011

    kdesign7 macrumors 6502a

    Joined:
    Feb 1, 2010
    Location:
    earth, for now.
    #1
    Strange - Im sure there is an easy solution.

    I plugged my iPad 2 into the computer. Went to iTunes, and selected RESTORE - and it prompted me with RESTORE & UPDATE. I let iTunes do its thing - but the iPad 2 hangs up. The loading progress bar seems to be nearly 95% complete but goes no further...

    Where can I download the 4.3.3 FIRMWARE - Because I noticed that when I hit Restore - iTunes went right into EXTRACTING and then onto another process. I didnt see it download the 4.3.3 - and I was previously on 4.3

    EDIT - Alrite so looks like things are great now. I actually found the firmware from iClarified and it worked solid. So... Problem solved!
     
  2. nas1289 macrumors newbie

    Joined:
    Oct 20, 2011
    #2
    restore ipad 2

    hii

    this is happening to me now!!!:(:(:(:(:(:(

    How did u fix it? i want to know everythingggggggg!!!!

    i tried changing the apple server host thingy lol i tried manually downloading the new ios 5 so restoring it myself but no.

    So im open to options!!

    thanks!
     

Share This Page