Can't send email when not on my home wifi

Discussion in 'iPhone' started by flgator85, Jun 10, 2011.

  1. flgator85 macrumors newbie

    Joined:
    Aug 12, 2010
    #1
    I use roadrunner as my email. I also have my own domain that I forward my email to my roadrunner email address. I have configured my email using the settings at http://help.rr.com/hmsfaqs/e_rrmail_emailSettings_iphone.aspx. I have double check it. When setting up my email I use my domain email address. I have configured the pop-server to point to my roadrunner email address and I point the outgoing server to also use my roadrunner account. This work perfectly fine when I am at home. I am able to send emails. The problem is that when I am on AT&T wifi network or some other wifi network I get an error that I my domain email address was rejected by the server.The only way to get it to send is to turn off wifi and use 3G. It then sends properly. This use to work for the past 2 years, but has stopped working. There were no changes on my end except the upgrades to new 4.3.x iOS upgrades. I didn't notice when this stopped working and whether it was due to an iOS upgrade or a change on by roadrunner on their servers.

    If I change the return email address from my domain email address to my roadrunner email address, it send fine both at my home wifi and at AT&T wifi network. I have contacted roadrunner help support. They were less than helpful. After 5 emails and 5 response from them, they said it was an Apple issue and that I should contact apple. Has anyone else noticed this issue?


    John
     
  2. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #2
    Ugh. Annoying. This is actually why I switched to g-mail. I tried using my own domain e-mail with my first iPhone and it was a mess. G-mail just worked so I switched.

    But that doesn't help you. The best advice I can give is that I think you can set 2 out-going servers in the mail settings and it should go from one to the next if the first one doesn't work. What's the setup look like in there right now? Is there more than one? What are they? Knowing that will help you figure out what to do next.
     
  3. flgator85 thread starter macrumors newbie

    Joined:
    Aug 12, 2010
    #3
    I have several outgoing mail servers set up. I have cwmx.com (for when I am on 3G), smtp-server.cfl.rr.com without username/password (for when I am at home), smtp-server.cfl.rr.com with username/password (for when I am another wifi network not roadrunner), and mobile-smtp.roadrunner.com with username/password. For the servers with username/password, the port is set to 587 and the authentication is set to password. I have tried turning off the smtp-server.cfl.rr.com, but that did not help. If I change the return email address from my domain email address to my roadrunner email address, it send fine both at my home wifi and at AT&T wifi network.

    Like I mention it use to work, but stopped. I then tried mobile-smtp.roadrunner.com per the link I provide.
     

Share This Page