Cant send emails using GPRS/EDGE or 3G?

Discussion in 'iPhone' started by draperm25, Oct 26, 2008.

  1. draperm25 macrumors regular

    draperm25

    Joined:
    Sep 19, 2007
    Location:
    Swansea
    #1
    HI all,


    I am having problems sending emails from my iPhone using GPRS/EGDGE or 3G network, the only way i can send emails is by using Wi-Fi. I havent really noticed it before as i dont normally use email outside the house which i have a Wi-Fi connection so i have never noticed. If i try sending an email over these networks it comes up sending then about 2mins later it says,

    The connection to the outgoing server "smtp.provider.com" failed.

    so i press ok and it leaves it in the outbox, and says on the iPhone,
    "1 Unsent Message"

    But as soon as i get home (in the Wi-Fi connection area) my email will send?

    Can anyone advise me on what to do.

    I have a 16GB White iPhone PAYG.
     
  2. ParishYoung macrumors 6502a

    Joined:
    Mar 18, 2008
    Location:
    Bristol, South West UK
    #2
    Hi,

    Who is your email provider?
    What settings do you have for the "Outgoing Mail Server" in the iPhone?
    Who is your Carrier / Network?

    First impression here is that your email it setup to use the Outgoing Server of your home Broadband / Internet ISP. This wont work on the phone when you're using a data network.

    The info above should help us solve this for you.
     
  3. Flhusky macrumors 6502a

    Flhusky

    Joined:
    Aug 28, 2007
    Location:
    Florida
    #3
    1 quick question, does it work on ANY other wireless network?

    1 answer: Most ISPs do not allow 'relaying' email from outside their network. Some allow it if you authenticate but most don't. Sooo if your trying to send mail via smtp.localISP.com on your home wireless it will work, go to a local coffee shop and it should fail as it will fail on AT&Ts network because your not on a trusted connection.

    in other words, yes this is normal. To confirm it call your ISP and ask them about using the smtp server from outside the network.
     
  4. ParishYoung macrumors 6502a

    Joined:
    Mar 18, 2008
    Location:
    Bristol, South West UK
    #4
    Also,
    Do you have POP3 / IMAP email type (your email provider should be able to tell you this)??
     
  5. draperm25 thread starter macrumors regular

    draperm25

    Joined:
    Sep 19, 2007
    Location:
    Swansea
    #5
    My email provider is my local internet provider

    1.ntlworld
    2.[​IMG][​IMG]

    3.My Network Is O2

    I have pop3 email

    So is there anyway of using my email say outside my house when im nowhere near my wifi connection?
     
  6. Flhusky macrumors 6502a

    Flhusky

    Joined:
    Aug 28, 2007
    Location:
    Florida
    #6
    Unless they allow outside network access to their SMTP server, then no.
    You can send threw (must have an acct) yahoo or gmail.
     
  7. ParishYoung macrumors 6502a

    Joined:
    Mar 18, 2008
    Location:
    Bristol, South West UK
    #7
    Something to try.....

    Ok, I had a thought.

    Try the following steps and see if this helps you....

    on the iPhone
    1. Tap "Setttings"
    2. Tap "Mail, Contacts, Calendars"
    3. Tap on your mail account (it's the first in the list)
    4. Tap "Account Info"
    5. Tap "SMTP Mail Server"
    6. Tap "Primary Server"

    If you can edit the options here, see if you can activate the "Use SSL" option, and then set the username and password to the same as you use for the Incoming Mail Server / Login
     
  8. ParishYoung macrumors 6502a

    Joined:
    Mar 18, 2008
    Location:
    Bristol, South West UK
    #8
    Something to try..... (alterntive)

    I found this over on the O2 support pages:

    "We recommend you use your own ISP Outgoing server with your ISP username and password. However if your ISP doesn't support this you can use smtp.o2.co.uk and if your device has an option for a username and password for the Outgoing Server you should enter your full o2.co.uk email address and o2 password. Your o2 email address is the username you set up - e.g. joe.bloggs becomes joe.bloggs@o2.co.uk"


    To use this info try these steps:

    on the iPhone
    1. Tap "Setttings"
    2. Tap "Mail, Contacts, Calendars"
    3. Tap on your mail account (it's the first in the list)
    4. Tap "Account Info"
    5. Tap "SMTP Mail Server"
    6. Under "Other SMTP Servers" tap where is says "Add Server..."
    7. Set "Host Name" to "smtp.orange.co.uk"
    8. User Name - leave blank
    9.Password - leave blank
    10. Tap "Save" button

    After a while (a few minutes for me) this may fail and ask if you want to try without SSL, say "yes" to this.

    This should leave you with your NTLworld server as the Primary for when you are within the reach of your Wifi router, and then while you're out and about it should move over to the O2.co.uk server.

    Beyond this I can only recommend either calling O2, as they are bound to have setup instructions for iPhone users using their own email providers.

    And Finally there is a support forum for iphone users over at www.o2.co.uk where you may be able to find someone in your exact same situation.

    Hopeall this helps. Let us know how you get on.
     
  9. draperm25 thread starter macrumors regular

    draperm25

    Joined:
    Sep 19, 2007
    Location:
    Swansea
    #9
    well I chnged my SMTP to SMTP.o2.co.uk and put in my username and Password and it works hooray LOL, thanks very much for your help guys
     

Share This Page