Can't Send Emails with Apple Mail!

Discussion in 'Mac Apps and Mac App Store' started by superspiffy, Jul 11, 2007.

  1. superspiffy macrumors 6502a

    Joined:
    Feb 6, 2007
    #1
    Apple Mail can't send emails but it can receive them just fine. I tethered all my email accounts a while back to Apple Mail when I was at my school's network and everything worked fine but as soon as I went back home for the summer and hooked up my Mac to my home network, I am unable to get Apple mail to send emails. It always says, "Cannot send message using the server____." and it prompts me to choose other Outgoing Mail Servers. I do, but those never work as well. I've had this problem for a long time and no, rebooting doesn't help. What am I suppose to change in the settings? Is it a conflict with the port? What do I do?
     
  2. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #2
    Who is your ISP? Many ISP's only allow you to use their SMTP server to send mail. Change your outgoing mail server to your ISP's SMTP server and it should work.
     
  3. superspiffy thread starter macrumors 6502a

    Joined:
    Feb 6, 2007
    #3
    SBC global
     
  4. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
  5. superspiffy thread starter macrumors 6502a

    Joined:
    Feb 6, 2007
    #5
    no luck
     
  6. TheJayWay macrumors member

    Joined:
    Apr 18, 2007
    Location:
    Winnipeg, Manitoba, Canada
    #6
    I had roughly the same problem with my ISP internet mail a while back. I fixed it by turning authentication off. Works like a charm now!
     
  7. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #7
    Is it just SBC Global or is there a sub-provider? Here is a page that lists some of the possibilities.
     
  8. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #8
    Use the SMTP server that you use for your regular SBC mail account. Select it from the Outgoing Mail Server (SMTP): popup menu.
     
  9. kinai-ahi macrumors newbie

    Joined:
    May 18, 2007
    Location:
    San Clemente
    #9
    Me too!!

    I have a new MBP and Mail will not send my POP mail, but will receive fine. I have gone back and forth with Apple techs and my ISP techs and neither is much help.

    I have the SMTP set correctly and it still does not work....if you find a solution, please let me know.
     
  10. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #10
    What ISP are you on?
     
  11. kinai-ahi macrumors newbie

    Joined:
    May 18, 2007
    Location:
    San Clemente
    #11
    Cox Communications...
     
  12. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #12
    So I assume you're trying to use smtp.west.cox.net, right?
     
  13. klex macrumors regular

    Joined:
    Jun 28, 2007
    #13
    I had similar problems.

    The first time, my username wasn't typed correctly, and second time, Mail had set up a username and password for my outgoing server even though the server uses neither. All I had to do was delete the password and username and uncheck the box that says something like "username and password required".
     
  14. kinai-ahi macrumors newbie

    Joined:
    May 18, 2007
    Location:
    San Clemente
    #14
    Correct....
    Everything seems to be typed correctly. It receives, so I not sure why it won't send. Also, I notice that email received does not pull it from the server like my home computer. Why is this??

    Also, how do I get rid of my picture on e-mail sent? thanks for all your help!!
     
  15. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #15
    I assume Cox also doesn't require authentication and uses port 25...are those set up correctly?

    It's probably not deleting messages from the server as you download them due to a setting in Mail. In the Advanced sub-pane under the account in question, there's a check box to enable deletion from the server with a menu to specify when the deletion should happen.

    Picture 1.png

    I assume you're talking about the little image in the upper right corner of your message. That's just your machine's way of identifying you throughout your system. I believe it can be changed through the Accounts pane of System Preferences, through Address Book, through iChat, and I'm sure other places as well. That image is not included in the e-mail you send...it's just an internal display on your system.
     
  16. superspiffy thread starter macrumors 6502a

    Joined:
    Feb 6, 2007
    #16
    I have sbc global yahoo as my ISP. smtp.att.yahoo.com works. I can now send messages through all my email accounts (gmail, aol, uci webmail) but I still can't send pictures through any of them. I've tried sending the pictures as Small but still no effect.
     
  17. kinai-ahi macrumors newbie

    Joined:
    May 18, 2007
    Location:
    San Clemente
    #17
    Thank you

    Thank you...everyting seems to be working great. With the e-mail...I had to set the authentication to none. Now it works!!

    Also...mail is now off the server as I retrieve it!!

    Thanks
     
  18. Byrdbaldwin macrumors newbie

    Joined:
    Apr 8, 2008
    #18
    Apple Mail and smtp.sbcglobal.net

    Have been an sbcglobal.net customer for years, but recently we have been unable to send through their smtp.sbcglobal.net server - error came back that email address was rejected. Spent over an hour on the phone and finally got someone who explained that we are a "legacy account" meaning that we didn't need to use the newly upgraded smtp.att.yahoo to send. If you experience the same problem with the same circumstances (being a long-time customer), then you must call the internet service number on your AT&T bill and request a 2nd tier technical support advisor. They suggested that if this happens again, to not allow the technical advisor to register you through their new yahoo system, but to unlock the Port 25 to allow you to continue using the smtp.sbcglobal.net server.
     
  19. dakotaviolin macrumors newbie

    Joined:
    Mar 28, 2009
    #19
    Mac Mail Outgoing Server Trouble

    I am also experiencing problems sending (but no trouble receiving) emails through Mac Mail. I've used it for 2 years with no difficulty, but now suddenly am having problems. I wonder if this could be related to the fact that I just purchased an iPhone a week ago and am using the same outgoing server address? My server is Cox, and they assure me that there is no conflict but they are unable to help me, since they say that everything is ok from their end. I am unable to turn authentication off, as someone previously mentioned. Has anyone come up with any other solutions?

    Thanks.
     
  20. dakotaviolin macrumors newbie

    Joined:
    Mar 28, 2009
    #20
    Problem Solved

    As a follow-up to my last post, I solved the problem by unchecking the option of "use only this server" next to the listed outgoing server. It was checked, and I deselected it. Now it works fine...
     
  21. Whatathought macrumors newbie

    Joined:
    May 6, 2010
    Location:
    Tennessee
    #21
    I tried that and it works. Thanks so much.:)
     
  22. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #22
    This is an old thread, but I've recently had problems sending mail while setting up a couple of new Macs using Snow Leopard.

    Typically, after using the Mail setup assistant, one can receive emails but cannot SEND them out. Quite often, an alert will pop up saying that the password entered was incorrect -- even though you KNOW it's the right password.

    I believe the error may not be localized to Mail.app itself, but may actually have something to do with the way the Mail setup assistant works, or also how the password "key" is created in the user's keychain.

    I'm sensing that when the Setup Assistant creates the new mail account, and creates the password key, that _something_ is being "created amiss" (that is to say, "not quite right"). Thus, when Mail.app invokes that key in an effort to send mail, there is a conflict with the server/send process and an error is thrown up.

    This may explain why "turning authentication off" seems to correct the problem -- I'll guess that with authentication off, Mail.app is no longer using the password key stored in the keychain and instead waiting for manual input from the user.

    Here's what to do to fix the problem:

    - Open the Keychain Access application in the Utilties folder.
    - Unlock your keychain by clicking on the lock icon in the lower left
    - Locate the "passwords" that are stored in the keychain, and DELETE ALL that are related to the Mail.app (should be indicated by "POP" and "SMTP").
    - Quit Keychain Access
    - Now, re-launch Mail
    - Create a new "test email" to yourself
    - When you click send, the SMTP server will request a password, which will invoke the dialog asking for the password and if you wish for it to be stored in your keychain. Enter the password and CHECK the box to store the password.
    - Does it send succesfully, without an error?
    - If so, now choose the "get mail" option to receive the email to yourself.
    - Again, since there is no stored password, you will again be prompted to enter a password for the "POP" server. Enter it and again check to store it in your keychain.

    This got things working properly for me again.

    NOTE: It may be necessary to go into the accounts pref pane in Mail.app, and adjust your server ports, as well.
     
  23. Nicholas Newman macrumors newbie

    Joined:
    May 11, 2010
    #23
    I have the same problem on a PowerBook with Leopard and a white 13" MacBook with Snow Leopard.
    NONE of the solutions above is appropriate here, as there is NO authentication for outgoing SMTP traffic. Except that Fishrman mentioned "It may be necessary to go into the accounts pref pane in Mail.app, and adjust your server ports, as well".
    What works - Mail preferences, accounts, Outgoing mail server, edit SMTP server list (I have several, depending on what country I happen to be in), Advanced tab, Swap between "Use default ports" and "Use Custom port", putting in "25". After a while after a change, the same phenomenon comes back, to be cured generally by swapping back again, but sometimes it only works again after a couple of changes.

    It seems intermittent, OK for a few days then bad again. Could network quality variations have something to do with it?

    Would Apple like to tell us what on earth is going on? What is it that is obviously being reset or unblocked by our various and different home-brewed intuitive empirical recipes? I hate having to do things with being able to understand what's going on! It seems frequent enough for Apple to detect it.

    Another question - I also run PCs and have NEVER had this problem with Outlook or Outlook Express or Thunderbird on a PC, but I have not seen if Thunderbird would also get the problem on the Mac. Are there ather things than Apple Mail that have the problem too?
     
  24. raubin macrumors newbie

    Joined:
    May 13, 2010
    #24
    I have just had the same problem which seems to be down to my ISP closing off port 25 for outgoing mail. Simple solution of putting in custom port 26 by going to preferences >> accounts >> outgoing mail server smtp (dropdown) >> edit smtp server list >> use custom port >> 26.

    Can send out mail now, no problems :D
     
  25. Endura macrumors newbie

    Joined:
    Nov 16, 2010
    #25
    You fixed it!

    This worked perfectly for me! Thanks so much! I've been dealing with this issue for MONTHS with no help from Apple or SBC! I'm SO appreciative! I joined this post just to thank you!!!
     

Share This Page