iPhone Can’t send emails with wifi

Act3

macrumors 68000
Original poster
Sep 26, 2014
1,924
2,237
USA
On 13.3 I’ve noticed that emails won’t send if I am connected to WiFi. If I turn off the WiFi , they will send over cellular. I can receive emails fine over WiFi. Tried resetting email account and network settings.
 

niji

Contributor
Feb 9, 2003
1,822
1,703
tokyo
On 13.3 I’ve noticed that emails won’t send if I am connected to WiFi. If I turn off the WiFi , they will send over cellular. I can receive emails fine over WiFi. Tried resetting email account and network settings.
hi
due to some networks (ethernet, cable, or wifi) scanning for spam and other filters, sometimes you need to change the incoming/outgoing ports that your Mail is attempting to use. also, some internet gateways require mail being sent through them have SSL.
i haven't heard of an iCloud associated address having problems before. but email accounts using other mail providers/servers can have these problems.
check with the company you use for yr email account to give you alternative ports to use and see if that helps.
 
Last edited:

Act3

macrumors 68000
Original poster
Sep 26, 2014
1,924
2,237
USA
hi
i can
due to some networks (ethernet, cable, or wifi) scanning for spam and other filters, sometimes you need to change the incoming/outgoing ports that your Mail is attempting to use. also, some internet gateways require mail being sent through them have SSL.
i haven't heard of an iCloud associated address having problems before. but email accounts using other mail providers/servers can have these problems.
check with the company you use for yr email account to give you alternative ports to use and see if that helps.
I use the settings that my internet provider gives me. The email works fine on cellular with those settings. On Public WiFi , I cannot send emails. Turn off WiFi , they send fine.
 
  • Like
Reactions: niji

niji

Contributor
Feb 9, 2003
1,822
1,703
tokyo
I use the settings that my internet provider gives me. The email works fine on cellular with those settings. On Public WiFi , I cannot send emails. Turn off WiFi , they send fine.
as i said, the ports you use while on wifi may be different.
hope you find the solution.
 

Act3

macrumors 68000
Original poster
Sep 26, 2014
1,924
2,237
USA
as i said, the ports you use while on wifi may be different.
hope you find the solution.
port 587 is pretty much standard for smtp. I deleted the Apple mail app and then reinstalled.

thought it fixed it but nope. Still broke and of course spectrum wants to blame Apple and iOS. The only WiFi I can send on is my house WiFi or any public spectrum internet WiFi.
 
Last edited:

Ruggy

macrumors 6502
Jan 11, 2017
409
237
If you are using IMAP you need to set up the account so that you enter your user and password in advanced settings for the outgoing SMTP server.
You may think you have already done that but bear with me.
Usually, when you set up the account you follow the procedure/dilogue, enter your details and follow through until you are told it works.
But, entering the user and password separately for the SMTP server is optional by default and I have found that it doesn't then work over wifi.
So what you have to do in the 'Mail' tab in the address bar go to 'Preferences' then 'Accounts and navigate to the email address in the pane on the left. Then across to the pane labelled 'Server settings' and re-enter your user name and password there again. It will be blank by default.
Use port 587 (usually), enable TLS/SLS and authentication= password (they probably won't need changing)
Ant then it should send emails over wifi.
 
  • Like
Reactions: PieVsCake

Act3

macrumors 68000
Original poster
Sep 26, 2014
1,924
2,237
USA
If you are using IMAP you need to set up the account so that you enter your user and password in advanced settings for the outgoing SMTP server.
You may think you have already done that but bear with me.
Usually, when you set up the account you follow the procedure/dilogue, enter your details and follow through until you are told it works.
But, entering the user and password separately for the SMTP server is optional by default and I have found that it doesn't then work over wifi.
So what you have to do in the 'Mail' tab in the address bar go to 'Preferences' then 'Accounts and navigate to the email address in the pane on the left. Then across to the pane labelled 'Server settings' and re-enter your user name and password there again. It will be blank by default.
Use port 587 (usually), enable TLS/SLS and authentication= password (they probably won't need changing)
Ant then it should send emails over wifi.
Mines already setup like that. Works on home WiFi , but does not work on work, hotel or Disneyworld WiFi. Have had username and password in SMTP settings for years.
 

danmart

macrumors 65816
Apr 24, 2015
1,287
725
Lancs, UK
@niji is right that some WiFi networks can force you to use specific mail credentials which are other than your ‘native’ credentials.

Can you send emails when on your home WiFi? This sort of thing is normally only encountered in hotels, offices and so on.
 
  • Like
Reactions: niji

Act3

macrumors 68000
Original poster
Sep 26, 2014
1,924
2,237
USA
Try port 465. That's the standard port for encrypted SMTP. 587 is for unencrypted SMTP.

You could also try ports 25 and 2525. Port 25 is legacy (unencrypted) SMTP but most providers have blocked that privileged port years ago due to excessive spamming.
thanks. Just tried all three of those ports. None worked until I turned off WiFi, then they all do. I’ll just use cellular to send Emails for now. Not sure what else to do as my ISP wants to blame Apple.
 

niji

Contributor
Feb 9, 2003
1,822
1,703
tokyo
Try port 465. That's the standard port for encrypted SMTP. 587 is for unencrypted SMTP.

You could also try ports 25 and 2525. Port 25 is legacy (unencrypted) SMTP but most providers have blocked that privileged port years ago due to excessive spamming.
ah yes. 2525.
needed to use that port many times on hotel/publc/cable internets in the past.
it was a good fix a lot of the time.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.