Can't send iMessages on Messages

Discussion in 'OS X El Capitan (10.11)' started by skubaman, Jan 28, 2016.

  1. skubaman macrumors newbie

    Joined:
    Sep 29, 2010
    #1
    Hi all,


    I am running El Capitan 10.11.13 on a MacBook Pro Retina. I used to be able to send iMessages through Messages app to OS X and iOS devices with no problems. Recently it has started switching to send messages to iOS devices as SMS, which always fails, even if I have it enabled on preferences. I can't send to emails addresses enabled for iMessages. Pretty much, Messages currently only allow me to communicate via jabber accounts.


    I have already researched a lot here and other forums, tried many things and nothing worked. Tried removing accounts and adding again, signing out and signing back in, restarting, etc... Northing works.


    This has not been a problem before, but I wonder if the issue could be related to my Apple ID being my gmail address, which is also setup on Messages for Google Talk (jabber). I would remove Google Talk but it doesn't allow me, the minus button is disabled for some reason.


    Any suggestions to try to fix it?


    Thanks
     

    Attached Files:

  2. skubaman thread starter macrumors newbie

    Joined:
    Sep 29, 2010
  3. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #3
    I would try signing out of iCloud and then signing back in, if you have not tried that already.

    A.
     
  4. skubaman thread starter macrumors newbie

    Joined:
    Sep 29, 2010
    #4

    Thanks for advice. Just did this. SIgned out, restarted, signed back in. Issue do continue.

    I have been able to remove my Google Talk account by removing from Internet Accounts. But still can't send imessages to iOS phone numbers and still can't send imessages to email address that allow imessages.

    In both cases, I can't send, even if on the drop down says it's an imessage account.

    See images

    Thanks
     

    Attached Files:

  5. iLG macrumors member

    Joined:
    Sep 30, 2011
    #5
    Its not related to iCloud.
    Its not related to your Gmail address being used as your Apple ID.

    I just looked @ your screen shot. You have shown us your Google Talk settings not the mac Messages settings.

    What is your "Start new conversations from" set to?

    If you have iPhone check that your number is registered in the "Send & receive" settings in message settings. & try signing in with your Apple ID there.

    Simply signing out of Mac Messages & signing back in can help too.

    Try also deleting the conversation history with the recipient & starting a fresh message with that contact.

    Another possibility is that the people you are sending to don't have a network connection

    I had this issue the other day can't remember what fixed it. I think it was because I had changed my Apple ID & password
     

Share This Page