Can't send mail on iPhone via MobileMe

Discussion in 'iPhone' started by christopher3071, Aug 5, 2008.

  1. christopher3071 macrumors regular

    Joined:
    Sep 18, 2007
    Location:
    Upstate, NY
    #1
    But I can receive it fine.. Every time I try to send mail with my MobileMe account I get this error:
    Cannot Send Mail
    The connection to the outgoing server "smtp.me.com" failed.

    I can receive mail and send mail from my other accounts set up on my iPhone, it's only the MobileMe account that won't let me send.

    This is getting really frustrating as my .Mac account did this to me before MobileMe was released and obviously apple hasn't fixed the bug.
    Anyone know how to fix this? Anyone have the same problem?
     

    Attached Files:

  2. ktolani macrumors newbie

    Joined:
    Aug 5, 2008
    #2
    your screenshot shows that u r using wi-fi to send the email via iphone. that means, the problem is not in your iphone.. the problem is with ur Internet provider. they have blocked email sending through their server ports. u might want to contact your provider for that. you should be able to send emails via yr iphone when u use AT&T's 3G or edge network! i predict that u must be having similiar problems with your mail aplication?

    i had the same problem with me and that is wht i found. (my internet provider blocked the server ports from sending mail via Mail applications.) however, if you do have the same problem with your desktop mail application, you want to understand the following.

    the default port service for outgoing mail is port 25. you can change your port number to 143, 465 or 587. and try if any of those works. if none of them works, contact your provider.

    here is an article on problems with out going mail. it might help.

    http://www.gmpservices.com/Support/...ss.ISP.port.25.block.outgoing.mail.block.aspx

    to change your port from your mail application (if you use mac)
    1) open your mail application
    2) select mail - preferences
    3) on the left pane select your mobile me account
    4) on the account information tab, look at "outgoing mail server (SMTP)"
    5) on the drop down list, select edit server list.
    6) select the advance tab, and there you can find a small box where you can try to change different ports.
    7) apply and try it

    you can do the same with your iphone, by going to settings and mail settings then select your account and account info and on the bottom where there is "outgoing mail server" select the advance tab, and there you can change the ports while u use wi-fi. (you don't want to mess up the ports when you r connected to edge or 3g).

    hope this gives u an idea!
     
  3. christopher3071 thread starter macrumors regular

    Joined:
    Sep 18, 2007
    Location:
    Upstate, NY
    #3
    Got it.

    The issue happened when I wasn't home, it first started when using cell signals. In fact, sending via MobileMe on my iPhone never did work to start. But, since I updated to 2.0.1 and reset all my settings, I deleted my MobileMe account from my Mail app on my Macbook, and also off my iPhone in the Mail settings, then I added a 'new' MobileMe account through my iPhone and it worked! So I finally got it to work, still don't know what the deal was, I was on support chat with an apple employee for a good two hours and that is what happened in the end. Thank you so much for your support, I hope someone else can benefit from your extensive post. Hopefully this thread doesn't disappear into the land of dead, unvisited macrumors threads.
    Thanks again all for your help.
     
  4. ktolani macrumors newbie

    Joined:
    Aug 5, 2008
    #4
    you r welcome :)
     

Share This Page