Cant send mail with bt broadband!

Discussion in 'MacBook Pro' started by clancyjack, Mar 11, 2013.

  1. clancyjack macrumors newbie

    Joined:
    Mar 11, 2013
    #1
    Hi there,

    I am having problems with an email address that is hosted by a company called www.daily.co.uk.

    When I am at home and connected to BT broadband I am unable to send emails from the email address that is hosted by the above company. This is the same for my brother too when he connects to his Bt broadband at home. Whenever we connect to any other provider it is absolutely fine and sends mail. (it is only this email address that wont send, my gmail works fine)
    The error that appears is as follows: Mail was unable to connect to server “mail.daily.co.uk” using SSL on the default ports. Verify that this server supports SSL and that your account settings are correct.

    I have spoken at length with both Daily and Apple as i am using mac mail and they say it isnt a problem from them but must be a problem caused by BT.
    I have tried changing the ports etc and all sorts but this does not work

    I am moving to a new office soon that we are getting BT broadband installed in and so I must either have a solution/know that it wont work very soon so that I can cancel the BT broadband and find another provider that works.

    Please anyone help me!!!!!!!

    Bt arent helpful on the phone either!!!
     
  2. xShane macrumors 6502a

    xShane

    Joined:
    Nov 2, 2012
    Location:
    United States
    #2
    I know this sounds silly, but have you verified that you can use SSL for that email?

    Also, do you have the IMAP/POP correctly set up?
     
  3. clancyjack thread starter macrumors newbie

    Joined:
    Mar 11, 2013
    #3
    Hi there,

    Yeah I can use SSL indeed and it is set up as per their website. It works with every other internet provider, when i am in the office it works fine. It only effects outgoing mail when I am connected to BT!!

    Its so weird and is a big problem for me!!
     
  4. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #4
    Never use an email address from your ISP. It locks you in to their service and there are so many free alternatives.

    PS I'm under the impression that BT routers are right rubbish 802.11g 10/100 fossils. May I inquire which model you have?

    Opps. The OP is using third party email.
     
  5. xShane macrumors 6502a

    xShane

    Joined:
    Nov 2, 2012
    Location:
    United States
    #5
    I would second that.

    Switch email providers if possible (Gmail is great).
     
  6. clancyjack, Mar 11, 2013
    Last edited: Mar 11, 2013

    clancyjack thread starter macrumors newbie

    Joined:
    Mar 11, 2013
    #6
    Hi I am not using a BT email but an email address hosted by a company called daily.co.uk. The reason for this being I need to have an email address that is (@krankbrother.com) its the name of my company. Daily.co.uk simply host the email address. Maybe thats not what you meant and you know this though?!
     
  7. TonyHoyle macrumors 6502a

    Joined:
    Sep 14, 2007
    Location:
    Manchester, UK
    #7
    BT block all outgoing mail except via their own mailservers. It's quite common for the mass-market internet providers to do this (as they sell to those that are more likely to have compromised machines sending spam).

    You may be able to use the BT mailserver to send the daily.co.uk emails (provided they don't force you to use @btbroadband.com email addresses) - a better alternative would be to switch to using webmail, which will work anywhere.
     
  8. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #8
    OP: remove your MAC address from your post. That's not a model number.

    Anyway your external email server won't be port blocked but may not work with your email client or require two layer authentication. See if they support webmail as that'll work when your ISP blocks ports.
     
  9. clancyjack thread starter macrumors newbie

    Joined:
    Mar 11, 2013
    #9
    Hi,

    My webmail works fine but it is a shockingly bad site, really low budget and outdated so I really want to get it to work through Mac Mail, When I spoke to BT they said that they dont block any ports though. Its such a silly problem really!!!
     
  10. 0dev macrumors 68040

    0dev

    Joined:
    Dec 22, 2009
    Location:
    127.0.0.1
    #10
    Yo, fellow BT customer here.

    First thing to do is take your BT Home Hub and throw it in the bin. Those things are a POS and I am 99% sure that's causing your problems.

    If you have Infinity (fibre optic) then you can pretty much buy any modern router and hook that up instead. Cisco are generally very good but any reasonable modern router will do a better job than what BT give you.

    Switch the router and see what happens, I'm quite sure that'll fix it. I know for a fact that BT does not block ports for mail providers that aren't their own (I can use GMail in the Mail app just fine) but the Home Hub causes all sorts of cockups.
     
  11. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #11
  12. clancyjack thread starter macrumors newbie

    Joined:
    Mar 11, 2013
    #12
    @blueroom. Yes I set it up using that web pages instructions. Is there another way of doing it?

    Thanks for all the help by the way everyone!!
     
  13. clancyjack thread starter macrumors newbie

    Joined:
    Mar 11, 2013
    #13
    @0dev

    Is it relatively easy to set up a new router.
    I also have a booster that was installed would putting in a new router affect the booster?

    Jack
     
  14. 0dev macrumors 68040

    0dev

    Joined:
    Dec 22, 2009
    Location:
    127.0.0.1
    #14
    Setting up a new router on BT is very easy yes, you can get it up and running from the web interface of most routers in under 10 minutes. The settings you need to enter are very simple, for the username put "your.name@btbroadband.co.uk" and put "BT" as the password. For everything else the defaults should work.

    Do you have Infinity or are you still on ADSL2?

    Not sure what a booster is. Where physically is it in your setup?
     
  15. clancyjack thread starter macrumors newbie

    Joined:
    Mar 11, 2013
    #15
    The booster is just a netgear router that is connected to the BT router, the BT routers signal doesnt reach far enough at all!!!
    Ok great I think I will have to try that then!!

    Thanks
     
  16. 0dev macrumors 68040

    0dev

    Joined:
    Dec 22, 2009
    Location:
    127.0.0.1
    #16
    If it's a piece of Netgear kit set up as a signal booster for the WiFi that should work fine with any decent new router, yes, but maybe you should just look at a router with a longer range.

    You might want to try borrowing a router from a friend to test the email situation out before spending any money but I am pretty sure that's what's causing your problem.

    MAKE SURE you get a router compatible with your connection though. If you are still using ADSL2 you need a router that works with that type of connection. If it's fibre optic then you should be fine with any modern router.
     
  17. clancyjack thread starter macrumors newbie

    Joined:
    Mar 11, 2013
    #17
    I have infinity so as you say i will get a good modern one!!
     
  18. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #18
    Before you go buying new hardware, have you tried using BT's SMTP server as TonyHoyle suggested above? While I don't have any experience with BT specifically, I have run into the same thing with various ISPs and it does sound like this could be your issue.
     
  19. clancyjack thread starter macrumors newbie

    Joined:
    Mar 11, 2013
  20. chriscl macrumors 6502

    chriscl

    Joined:
    Jan 4, 2008
    Location:
    Stuttgart, Germany
    #20
    To set a default outgoing SMTP mail server for an account in Mac OS X Mail:

    Select Mail | Preferences... from the menu in Mac OS X Mail.

    Go to the Accounts tab.

    Highlight the account a default outgoing mail server of which you want to specify.

    Make sure the Account information tab is selected.

    Under Outgoing Mail Server (SMTP):, select the preferred server from the drop-down list.

    Click OK.

    Close the Accounts window.
     
  21. clancyjack thread starter macrumors newbie

    Joined:
    Mar 11, 2013
    #21
    Hi although doing the above does work. The recipient of the email sees is as being from whatever server I select to send it from. Is there a way of sending through a different server but so it sends from my @krankbrother.com account?

    ----------

    Sorry I meant send through a different server but to the recipient it looks like it has sent from my @krankbrother.com account.
     
  22. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #22
    Changing the SMTP server should not have affected that. Check that the "Email Address" field in Preferences > Accounts is set correctly.
     
  23. clancyjack thread starter macrumors newbie

    Joined:
    Mar 11, 2013
    #23
    It says it is coming from the @krankbrother.com in preferences but then it doesnt!!!

    This is getting ridiculous isnt it!!
     
  24. snorkelman macrumors 6502a

    snorkelman

    Joined:
    Oct 25, 2010
    #24
    create a spare gmail account

    setup a mail redirect for your problem email address so all its mail goes there.

    next log into that gmail account vie web browser and edit gmail settings for the new gmail account. Add your problem email address as the default address for mail sent from that gmail account (its under settings/Accounts and Imports in gmail web site)

    next add the new gmail account to the mac mail app

    finally, go into mac mail app preferences, find that new gmail account and edit its email address so it now tags outgoing mail with your problem email address rather than the gmail address.

    voila provided your email provider will allow a redirect to gmail, then all email will now go to the gmail account, while all replies and new mails sent via that gmail account in the mac mail app will have your email address as the sender.
     

Share This Page