Cant send photos directly via sms?

Eagle1337

macrumors regular
Original poster
Feb 9, 2017
146
168
Denmark
Hi guys,

after i got my new XS Max i cant send pictures directly via SMS from the photos album. I tried to google on the issue and found that if there's any MobileIron or the like it could prevent the functionality to send a picture directly via anything else than mail, but its a private phone with no management on top of it.

Anyone know how to get the functionality back, so that i can send a picture directly to a friend via SMS from within the photo album?

please see the foto, i only have the possibility to share via mail, where i used to have a lot more possibilities including sms via text message (i have only marked one picture):
options.JPG


any ideas please.

thanks,
Soren
 

alpi123

macrumors 65816
Jun 18, 2014
1,019
954
If you go to setting, messages, do you have MMS turned on?
Why not send the photo right in the iMessage app?
 

Eagle1337

macrumors regular
Original poster
Feb 9, 2017
146
168
Denmark
Hi Alpi,

thanks for your reply.

I have mms enabled, but i dont use iMessage. i had an episode with iMessage some years ago where the receipient was in another country not covered by mobile data, and no wireless access, in that case i could not see the message was not delivered, and of course the receipient could not see that i tried to send a mms. Hence never used it ever since.

I also dont use iMessage on my company iphone (7) however the mechanism of sending a picture via sms directly from photo roll works perfect. Hence i think its something on my new iphone which has gone bad.

soren
 

alpi123

macrumors 65816
Jun 18, 2014
1,019
954
So that's the issue. I just disabled iMessage and the button from the Picture app is now gone for me too.
If you want to share pics directly from Photo Gallery, you need to turn on iMessages, even if you're not using it.
 
  • Like
Reactions: keysofanxiety

Ulenspiegel

macrumors 68040
Nov 8, 2014
3,070
2,268
Land of Flanders and Elsewhere
Hello Soren,

MMS and Mobile Data have to be turned on. Please, check at the same time the MMS settings for your Cellular Operator (Settings ⇒ Mobile Data ⇒ Mobile Data Network ⇒ here set all neessary data). APN settings for Danish Cellular Operators you can find here.
 
  • Like
Reactions: Eagle1337

Eagle1337

macrumors regular
Original poster
Feb 9, 2017
146
168
Denmark
Hello Soren,

MMS and Mobile Data have to be turned on. Please, check at the same time the MMS settings for your Cellular Operator (Settings ⇒ Mobile Data ⇒ Mobile Data Network ⇒ here set all neessary data). APN settings for Danish Cellular Operators you can find here.
Hi Ulenspiegel,

thanks a bunch for your reply, its appreciated.

I checked the mms settings and they were almost like in your link, so i adjusted it to fit. (port 8080 was mentioned after the ip, and the max size of mss was significantly smaller than in the link, so increased it as well). but sadly it didnt seem to do the trick.

its definately not related to the usage of iMessage as suggested by alpi123, as it works on my company phone which also doesnt use iMessage.

would it help maybe to reset phone / network settings? the APN settings on the company phone just states "internet" under APN settings, but its another provider. just find it strange that its enough, not fully qualified or anything. just "internet". and on my provider its www.internet.mtelia.dk. strange.

i never had this issue before on any of my iphones.
 

Eagle1337

macrumors regular
Original poster
Feb 9, 2017
146
168
Denmark
Sadly issue still persist, maybe i should try to erase and reinstall the phone. if anyone has any ideas please let me know.

thanks,
soren
 

chabig

macrumors 603
Sep 6, 2002
5,892
3,142
Thanks for the picture. I suspect it's the MobileIron management software. If you delete your corporate email account, I bet you get the SMS option back. I have a private iPhone, but as soon as I set up my corporate Exchange email account, I'm subject to our corporate passcode policies.
 

Eagle1337

macrumors regular
Original poster
Feb 9, 2017
146
168
Denmark
Thanks for the picture. I suspect it's the MobileIron management software. If you delete your corporate email account, I bet you get the SMS option back. I have a private iPhone, but as soon as I set up my corporate Exchange email account, I'm subject to our corporate passcode policies.
Hi Chabig,

thats the strange part - i have a company iphone 8 which is under heavy mobile device management, it can send pictures directly via sms without issues.

However my private phone which has nothing like it, was not able to send pictures via sms from day one after activation. it really puzzles me, and its super annoying, after i got the XS Max, i realized how many times i have a photo which i would like to send directly, but cant. i never noticed before as it used to just work.

this is killing me. when i have some time in the weekend i will try to reinstall it to see if it fixes anything.
 

Eagle1337

macrumors regular
Original poster
Feb 9, 2017
146
168
Denmark
Hi all,

Would really appreciate if someone could help me out on this issue.

please let me know if you have an idea.

Thanks
Soren
 

Eagle1337

macrumors regular
Original poster
Feb 9, 2017
146
168
Denmark
Hi all,

just wanted to share that it was a corrupted icloud backup which kept giving me this issue. i deleted the iphone, reset as "new" and just let the data sync back without using the icloud backup. Then i delete the old icloud backup and create a new with this new "intact" dataset.

thanks
soren
 

Eagle1337

macrumors regular
Original poster
Feb 9, 2017
146
168
Denmark
Noo it was actually still an issue, its just because iMessage is enabled after a reset by default. When i disabled iMessage the issue came back. Spoke to Apple Engineer, they said its a known bug and that they are looking into a resolution in an upcoming IOS patch..