Can't set safari as the default browser

Discussion in 'OS X El Capitan (10.11)' started by mcdaddy, Jul 10, 2015.

  1. mcdaddy macrumors newbie

    mcdaddy

    Joined:
    Jul 3, 2015
    Location:
    On a tree
    #1
    Tried to set safari as the default browser, but chrome continues to stay the default one.

    Anyone noticed this?

    I recently converted to safari after I installed El Capitan. So I am unsure if it is El Capitan specific issue, or general safari issue.

    thanks
     
  2. !!! macrumors 6502

    !!!

    Joined:
    Aug 5, 2013
    #2
    How are you trying to set the default browser?
     
  3. mcdaddy thread starter macrumors newbie

    mcdaddy

    Joined:
    Jul 3, 2015
    Location:
    On a tree
    #3
    Safari Settings --> General
    Then hit Set Default.

    I hope there isn't another setting elsewhere.
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    1. From the Apple menu, choose System Preferences, then click General.
    2. Click the "Default web browser" pop-up menu and choose a web browser, like Safari.
     
  5. mcdaddy thread starter macrumors newbie

    mcdaddy

    Joined:
    Jul 3, 2015
    Location:
    On a tree
    #5
    Bingo. That was it. But, very odd to have that setting in two places. No?
     
  6. MacClueless macrumors member

    Joined:
    Jun 21, 2006
    #6
    This pop-up is empty for me; there's nothing to choose (no text).
     
  7. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #7
    It was blank in my General tab also, until I clicked the disclosure triangle.
     

Share This Page