Cant share files on a Mc with Windows 7 PC

Discussion in 'Mac OS X Lion (10.7)' started by eljanitor, Aug 10, 2011.

  1. eljanitor, Aug 10, 2011
    Last edited: Aug 11, 2011

    eljanitor macrumors 6502


    Feb 10, 2011
    Has anyone heard of this? Someone wants to put a file server in their windows network. So they go into an apple store where the salesman tells them all they need to do is buy a mini with lion server on it and that will solve their problems.

    So after the Lion mac mini refuses to let anyone connect to it other then another mac. I try setting up a shared folder on a different Mac Using 10.6.8 (non server ) and so.......... Even with SMB enabled, all settings on the PC's and the mac set to the same work group name. Files shared on the mac with the windows users added to the Mac shared folders, given read write permissions. Firewalls set to allow SMB and netbios connections. (firewalls turned off didn't matter either).
    With all of this done the PC's will see the Mac with the shared folder on the network but will not connect period.

    So far I've done this: Followed all the steps and advice in this article: and still Windows 7 Ultimate will not connect?! I tried this on a mac running 10.6.8.

    Has ANYONE been able to get this to work successfully? I could use some advice.:confused:
  2. r0k macrumors 68040


    Mar 3, 2008
    Is the firewall running on the Mac? Quite often when something on the network that is supposed to "just work" mysteriously stops working, it's either the OS X firewall or on Windows it's Zonealarm.

    1 - In system preferences pick sharing. Make sure file sharing is checked and under options make sure you have a check mark for "share files and folders using smb."

    2 - On the windows side, the network "browser" service may ignore the Macs and you may have to put in the ip address of your Mac to connect to it. The Mac will want your user id and password but on the windows side it might be expecting to only provide a password but not both. Sorry my windows networking is getting a little rusty.
  3. AnneStuarto238 macrumors member

    Mar 19, 2010
    SL: Every mac-share is fine and appears instantly in win7

    Lion: No mac-share appear. And can't manually login..

  4. eljanitor thread starter macrumors 6502


    Feb 10, 2011
    I dropped both firewalls one the mac and on the PC at one point to eliminate them as an issue, it didn't do anything really. My windows filesharing is not as good as it used to be either. It used to be easier with previous os's. Now it's just some kind of nightmare like it was 5-7 years ago. Almost seems like The windows / mac file sharing garbage is back.

    But no it seems that even with the firewalls down, and the PC fully updated. Nothing will work. I don't want to touch the Lion server that is having the file sharing issues because I've read all the nightmare posts from others about Lions problems with file sharing.

    I'm open for advice on how to get this done if anyone has done it successfully recently.
  5. ohsnap macrumors regular

    Aug 5, 2004
    That's Apple for you, they do this type of thing all the time. In a years' time this will be mature enough that it won't be an issue but for now, we just have to deal with it. I have the problem where SMB shares aren't being seen by each other and are not shown in their respective network browsers but you can usually explicitly call the URL of the host computer. In Mac OS, go to the Finder, select 'GO > Go to Folder' then type 'smb://server/share'. Even though the Mac might not "see" you Win7 (make sure it is Win7 if you're running Lion), you might be able to mount the share that way. And same for Win 7, in the url bar type \\server\share and the Mac might pop up.
  6. eljanitor thread starter macrumors 6502


    Feb 10, 2011
    Windows 7 and Lion does fileshare sucessfully now?!

    Tried it on a Lion desktop drive and file sharing works between windows 7 and Lion. So I'm gonna try it on the Lion server later and see if that works too if I can. I have no idea why it wont work on Snow Leopard here, so whatever I guess with that problem solved for now. Thanks for your help everyone.

Share This Page