Can't share internet connection!?!

Discussion in 'Mac OS X Server, Xserve, and Networking' started by sequencester, Jan 30, 2012.

  1. sequencester macrumors newbie

    Joined:
    Jan 30, 2012
    #1
    I have read plenty of guides on how to share my ethernet connection through wireless so that my iPod and Xbox can connect to Wifi. Wifi is not available in my halls of residence. I know that a little up arrow is supposed to appear where the Airport icon is but it never does.

    Can anyone say why it might not be working for me? Are there ports I should be opening? Is it because I am at university?

    I have been trying for ages to get this to work. I am willing to post screenshots of my network set up if that is necessary.

    Any help is greatly appreciated,
    SM
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    I'm not sure, but I think it's a long standing bug. The problem I've been experiencing is that starting with Mac OS 10.5.5, the Mac never gives out an IP address to the other device(s) it's sharing its internet connection with. I've gotten the up arrow to appear by having my Mac create an ad-hoc network and messing with the Internet Sharing preferences a bit. But the other device still never gets an IP address from the Mac as it should. It does work after one is manually assigned to both the Mac and the device.
     
  3. sequencester thread starter macrumors newbie

    Joined:
    Jan 30, 2012
    #3
    So is this a unachievable goal for me?
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    I'm not sure. It could be that I've been over thinking my problem and not letting Mac OS X do its thing or one of my settings is incorrect.
     
  5. willieva macrumors 6502

    Joined:
    Mar 12, 2010
    #5
    It's pretty straightforward to set this up. Post a screenshot of internet sharing from your settings window. And post the output of
    /sbin/ifconfig -a
    from a terminal window.
     
  6. sequencester, Jan 30, 2012
    Last edited: Jan 30, 2012

    sequencester thread starter macrumors newbie

    Joined:
    Jan 30, 2012
    #6
    edit

    (beneath the black bar is my email address
     
  7. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #7
    You may want to black out all the IP addresses that start with 144.
     
  8. sequencester thread starter macrumors newbie

    Joined:
    Jan 30, 2012
    #8
    Done this now

    [​IMG]

    [​IMG]

    [​IMG]
     
  9. sequencester thread starter macrumors newbie

    Joined:
    Jan 30, 2012
    #9
    I have done this above
     
  10. willieva macrumors 6502

    Joined:
    Mar 12, 2010
    #10
    What happens when you click the Internet Sharing box to turn it on?
     
  11. sequencester thread starter macrumors newbie

    Joined:
    Jan 30, 2012
    #11
    Are you sure you want to turn on Internet sharing?
    If your computer is connected to a network, turning on Internet sharing may affect the network settings of other computers and disrupt the network. Contact your system administrator before turning on Internet sharing.

    I then click start but nothing changes, and the 'up arrow' that I have seen on video guides does not appear.
     
  12. sequencester thread starter macrumors newbie

    Joined:
    Jan 30, 2012
    #12
    Any ideas anyone?
     
  13. willieva macrumors 6502

    Joined:
    Mar 12, 2010
    #13
    It looks like you're doing everything properly. You might want to check the output in /var/syslog to see if there is any error happening when you start internet sharing.
     
  14. sequencester thread starter macrumors newbie

    Joined:
    Jan 30, 2012
    #14
    Sorry I don't know what this means
     
  15. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #15
    Open the Console.app application in /Applications/Utilities and look at the log file mentioned
     
  16. sequencester thread starter macrumors newbie

    Joined:
    Jan 30, 2012
    #16
    The problem I am having is that I am connected via 802.1 x and this is stopping it from working. Anyway around this?
     

Share This Page