Can't share NTFS hard drive to windows!

Discussion in 'Mac OS X Lion (10.7)' started by Max-via, Sep 24, 2011.

  1. Max-via macrumors newbie

    Joined:
    Dec 15, 2010
    #1
    Hi everyone,
    I've dektop with lion update,
    And I've movies and music in my westren digital 2TB hard drive(NTFS) I use tuxera to open,
    I want to share the hard drive from my mac to my windows computer via home network,
    The error Is : "Windows cannot access \\{mac name}\My Book 2TB"

    So what should I do ?, Help me please :|
     
  2. Madd the Sane macrumors 6502

    Madd the Sane

    Joined:
    Nov 8, 2010
    Location:
    Utah
    #2
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    Do you have the NTFS drive shared? If so, what does the Console app say when you try to connect to that mountpoint?
     
  3. Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
    #3
    Thank you for the reply,
    When I connect to my mac :apple: from my windows by home network, I can see all the files in mac hardisk (Main system hardisk) and open desktop, browse the content
    And I see the external hardisk but when i open it he give me this error:
    [​IMG]

    I hope you can help even with 3rd-party program
     
  4. ljonesj macrumors 6502a

    ljonesj

    Joined:
    Oct 20, 2009
    Location:
    Kingsport TN
    #4
    There is a known bug in lion that anything shared on the network that is not a apple filesystem it wont share. i have tried fat 32 xfat and ntfs none work at the moment
     
  5. Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
    #5
    So, What I do ? There is no app can fix it ?
    If I downgrade to SL it will work ?
     
  6. ljonesj macrumors 6502a

    ljonesj

    Joined:
    Oct 20, 2009
    Location:
    Kingsport TN
    #6
    Snow leopard will work but you can use the apple filesystem like hfs+ the network does not care what filesystem it is if its in share ( right now in a way it does care cause of that bug) but once its shared windows will see and you will be able to transfer what you want over the network as in that sense its in like a universal filesytem
     
  7. Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
    #7
    Thank you for the reply
    But there is no possible to share the NTFS ?, Or program ?
    I don't think is bug.
     
  8. Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
    #8
    Update

    UPDATE:
    I tried to convert my kingston usb(not the hard disk) to Mac OS Extended, and share it in my netword and worked in windows computer !!?
     
  9. Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
  10. Max-via, Oct 14, 2011
    Last edited: Oct 14, 2011

    Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
    #10
    Guys, please help me is there fix for this BUG ?, Because this is big problem for me :(
     
  11. ljonesj macrumors 6502a

    ljonesj

    Joined:
    Oct 20, 2009
    Location:
    Kingsport TN
    #11
  12. Max-via, Oct 14, 2011
    Last edited: Oct 14, 2011

    Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
    #12
    Thank you jones, I will try and Really HOPE this work :)
     
  13. Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
    #13
    :( :(
    Updated Tuxera NTFS to last update and download osxfuse, And still not woking :(

    Here pic [​IMG]

    "Movies" is in the hardisk
     
  14. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #14
    maybe not what you want but have you tried to plug the external in the Windows machine and use the Mac to share of it?
     
  15. Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
    #15
    I think am doing like that, But the problem I dont want to be there slow in browsing the movies and the series in my mac because I watch a lot in my mac,
    So if I connect the hard drive to windows and watch it via the mac there is no slow ?

    "PS:Sorry for my english"
     
  16. Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
    #16
    Hi,
    For now pluged the hard disk to the windows machine, just for now until the BUG sloved, Thank you guys :)
     
  17. phobox macrumors member

    Joined:
    Dec 25, 2007
    #17
    Actually there is a way to fix this, but it requires a little bit of manual work. Basically Lion's implementation of SMB (Windows-based file sharing) is a bit borked in that it will not share any volume that isnt formatted in HFS+. This is because Apple decided to do their own rewrite of SMB instead of using the open source Samba which previous versions of OSX used. The good news is there is a way to install the open source Samba3 and use that instead of Lion's version, thus allowing you share anything you want, from any volume (plus a much more flexible configuration options). I have it running here on 10.7.2, Im sharing all my NTFS volumes to my Windows machines without issue.
    As I said however this does require some manual work (only a little) as well as the installation of MacPorts. I can provide instructions for those that are interested, I would have included them in this post but Im out of time (duty calls).
     
  18. Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
    #18
    Thank you very much phobox, We are waiting for you warmly :)
     
  19. phobox macrumors member

    Joined:
    Dec 25, 2007
    #19
    Ok its fairly simple to install and get running, the hardest bit (which isnt really that hard) is configuring Samba itself and setting up your shares. Heres a rundown of what you need to do.

    1. Install MacPorts. Google MacPorts, you'll find the site and instructions for installing it. Note that it does require the latest XCode to be installed first.

    2. Open a terminal and type 'sudo port install samba3'

    3. Navigate to /opt/local/etc/samba3 and modify the smb.conf file to your needs. This is where you setup your shares. Theres plenty of documentation on the web for how to set this up correctly if you get stuck.

    4. Make sure that File Sharing is disabled in System Preferences (to prevent Lion's SMB from conflicting with the one you just installed).

    5. Once everything is setup you'll need to launch the smbd and nmbd services as deamons, do this by typing the following in Terminal:

    sudo /opt/local/sbin/smbd -D && /opt/local/sbin/nmbd -D

    If all went well, you should see smbd running when you look in Activity Monitor. If you setup your shares correctly in the smb.conf file above, you should be able to connect to them from your Windows machine as normal. Getting the shares all setup right is the hardest bit out of the whole thing.

    6. The last thing to do is set it up so that the smb deamon is launched automatically when you boot, thus preventing you having to run it manually all the time. Best way to do this is using an app called Lingon which will help you setup a plist which will tell OSX to launch the smbd and nmd automatically for you. On my machine I have my own script launching on boot which takes care of launching smbd plus doing a few other little things, but you wont need to do that on your setup.

    Theres a number of blog posts on the net that describe doing this in greater detail and which will probably be of more help than Ive been. I dont have the url's to hand but a quick google search should bring up some results. Im happy to help further if I can however.
     
  20. Max-via thread starter macrumors newbie

    Joined:
    Dec 15, 2010
    #20
    Thank you very very much phobox,
    now it didn't work, but am shore it will work after several attempts, I will do it again if apple didn't solve the problem in the next update,
    Again thank you very much phobox, and am shore there is a lot who have the same problem and they will search then read your post and this will solve their problem,
    Bookmarked the post, You are the best phobox :)
     
  21. Alyssa macrumors newbie

    Joined:
    Sep 29, 2003
    Location:
    Texas
    #21
    To follow photobox instructions you can just copy and paste the last sample configuration called [myshare] in the smb.conf and edit it according to your paths and user settings.

    Also by default there's only the smb.conf.sample so I just copied it and renamed it to smb.conf and used that instead.

    You can also create users and passwords using this command in terminal. Using the username alyssa as an example:

    sudo smbpasswd -a alyssa
     

Share This Page