Can't sign out of iCloud

Discussion in 'OS X Yosemite (10.10)' started by davidlv, Aug 24, 2015.

  1. davidlv, Aug 24, 2015
    Last edited: Aug 24, 2015

    davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #1
    Running 10.10.5, Can't sign out of iCloud in Sys prefs, can't uncheck the iCloud keychain access. It says "Waiting for authorization from other device", and in the options, using the code, and then the code sent to my cell phone does nothing. Any help here? Paging Weaselboy
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Try going to the iOS device and sign out of iCloud Keychain there, then see if the sign out sticks on the Mac.
     
  3. davidlv, Aug 25, 2015
    Last edited: Aug 25, 2015

    davidlv thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #3
    The phone I mentioned is not an iOS device, not even a "smart" phone, and it has never been connected to iCloud. I used it as an e-mail address only. My MBP was connected to iCloud, but I managed to turn iCloud Keychain off on that device.
    The MP just refuses, (has a exclamation mark and the message "waiting for approval from other device").
    Tried iCloud.com, using Chromium, intending to access the advanced settings, but I could not get access. An error message popped up, "There was a problem .... " typical worthless error message - with "send a report to Apple" and "OK" buttons. um.... That is certainly not OK .....
    Using Safari, I got access to the Settings page, but did not see how to sign out at all.

    The original keychain access issue persists....
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
  5. davidlv thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #5
    Thanks for your help anyway. I read another thread where someone else had the same issue, and someone suggested using icloud.com to change the settings, but that didn't work either.
    I figured that if someone with your experience couldn't help with a direct answer, it would take some heavy-handed method to do the job. So I brought my backup portable SSD from my MBP (which does not have that issue) over to the MP, booted from a secondary internal HD and simply copied all the ~/Library/apple.com preference files and the related apple files/folders in the /Library/Application Support folder over to the main MP SSD boot disk and rebooted.
    Voila, issue resolved. You will have to really twist my arm hard to get me to try using iCloud again!
    It is just too buggy and trouble for what it's worth. I was able to solve this issue 'cause I had bootable CCC clones, which makes me a little apprehensive about the advent of the use of SIP in El Capitan. Thinking about using OS X in the future, the rise of security concerns and Apple's "progress" in the development of OS X leaves a slightly sour taste behind. It is only the lack of a good alternative that keeps me from switching platforms. /end rant
     
  6. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #6
    This is both unpromising and disturbing.You should not be forced to such kludgery in order to get a simple permissions matter like this resolved.
     

Share This Page