Can't solve ImageCapture (-9934) error

Discussion in 'iMac' started by sppunk, May 2, 2017.

  1. sppunk macrumors member

    Joined:
    Nov 13, 2012
    #1
    Anyone know why I keep getting a -9934 error when I try to import with Image Capture? I refuse to store my files in the Photos app.

    I'm running a fully up-to-date Late 2015 iMac fwiw.

    I bought a new Nikon D5600 and it won't import files via ImageCapture. Files show up but I get the 9934 error when importing - I've tried multiple existing folders/sub folders/desktop. When I create a new folder on the desktop it does work, which is odd.

    Import worked fine last night with my older Nikon D5200, and I'm using the same memory card.

    Permissions should be read/wrote everywhere fwiw, I can move files around anywhere.

    Any ideas? I'd rather not buy a card reader.
     
  2. nambuccaheadsau macrumors 6502a

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #2
  3. sppunk thread starter macrumors member

    Joined:
    Nov 13, 2012
    #3
    That was my first thought but under Mac HD permissions for System, Wheel and User are set to Read/Write.

    I haven't run Repair yet, I had read in El Capitan it isn't necessary?
     
  4. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #4
    OP wrote:
    "Any ideas? I'd rather not buy a card reader."

    Buy a card reader. They're not that much more trouble to use.
    I -prefer- to use a card reader. Perhaps that's just me.

    Sounds like Image Capture may need an update to accommodate the new Nikon.
    (I'm thinking of getting the new D7500 when it's released)
     
  5. sppunk thread starter macrumors member

    Joined:
    Nov 13, 2012
    #5
    It's a last-chance option, I much prefer not having another gadget and prefer just plugging in camera.

    There are no updates available for IC, unfortunately. I may set an Apple support call about this actually. An new camera (using same info as one from 2015) should work on the updated Mac without issue.
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    I think that is not a good assumption that a new model camera, even if appears to have the same firmware, should work without issue. It's still a different model, eh?
    Maybe it works without updates - maybe not...

    Maybe this article will help... It covers more than iPhoto, but you also may want to know that the Photos app correctly identifies your Nikon, which may indicate that your system (including Image Capture) does, or does not, know what that device is that is trying to communicate with your Mac.
    Notice that article has a nice big caveat, which I can re-phrase: If you can't connect with your camera, use a support device like a card reader to get your pictures into your Mac - which, I assume, is your goal.

    I hear you when you say that you don't want to use Photos app, and I respect that. BUT, if you can import your pictures successfully into Photos, you can export out to another app, using Photos app as a tool for photo transfer only. (just a suggestion!)
     
  7. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #7
    I'll repeat:
    For the moment, a card reader will be much easier.
    They're cheap, and when not used for reading the camera card, I keep a spare SD card in it and use it for scratch storage, file transfers, etc.

    There's no way of knowing just how long it will be before Apple comes out with an update that supports the new camera...
     
  8. sppunk thread starter macrumors member

    Joined:
    Nov 13, 2012
    #8
    Bumping. I resolved this issue.

    The camera was resetting permission rights when plugging in + turned on. I redid permissions rights as the caveat was actively plugged in and now can get files out of ImageCapture.
     

Share This Page