Can't (sort of) mount external HDD

Discussion in 'macOS' started by sketchygio, Jan 28, 2010.

  1. sketchygio macrumors newbie

    Joined:
    Nov 1, 2009
    #1
    Hello,

    I've done a good 2 days of research on this and haven't found completely acceptable results.

    My issue is that my external hard drive (Rugged Lacie 500 GB), has decided for no good reason to not mount unless it's in a mounting mood. I don't know what triggers this behavior and it's been going on for a few days. Here's all I know:

    This seems to happen only when I use firewire connections. If it mounts, great. If not, nothing comes up on finder. Last time it didn't mount on my Macbook Pro (10.5.8), it still registered in my Disk Utility and I was able to manually mount it there (I right clicked both of the drive's partitions and selected mount). The last time I tried to mount it at work (different computer) it would not even come up in Disk Utility. The strange thing is that every time it doesn't mount, I can hear it spin normally, with no acoustic anomalies.

    Even stranger: every time it fails to mount via firewire, I have no problems mounting it via USB. And just because it's not mounting on a certain computer via firewire, doesn't mean it won't mount on the next. I'm perplexed. At first I thought my mac's firewire port was failing but now I am sure this is some fault within the ext HDD.

    Before anyone asks, yes I've tried restarting, yes I've tried different firewire cables. I backup data and format the hdd in hopes this will fix it, but does anyone know if this is a hardware issue? What could cause it to behave so strangely?:confused:
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    Are you using the external's own power supply (internal or "power block"), or are you using "bus power" when you make the connections?

    LaCie seems to have a bad rep for power supplies that fail prematurely.

    It could be something _else_ wrong with the enclosure, which the actual drive unit itself may be OK.

    Might even be a flaky firewire port on the enclosure.

    Perhaps the only way to determine whether the problem is "enclosure-related" or "drive-related" is to physically remove the drive from the enclosure, then test the drive by other means.

    That would involve another enclosure, or perhaps a "dongle" like this:
    http://www.newegg.com/Product/Product.aspx?Item=N82E16812119152
     
  3. sketchygio thread starter macrumors newbie

    Joined:
    Nov 1, 2009
    #3
    Thanks for the advice. I'm directly plugging the lacie drive to my mac without the USB power cable. I lost it, but that's definitely what I should try next.

    But if I wanted to get this repaired, I would need to buy a new enclosure? Same brand?
     

Share This Page