Can't start Accounts prefs pane and Disk Utility. Help!

Discussion in 'macOS' started by Stingray454, Apr 25, 2011.

  1. Stingray454 macrumors 6502a

    Joined:
    Sep 22, 2009
    #1
    I've seen a couple of crashes on my 2010 Air - it's started to hang while doing basic tasks, like browsing, watching a movie or sometimes while just displaying the desktop with no applications running. It doesn't seem to be a heat issue since I can play 3d games for hours sometimes without any problem.

    Today I started looking through the preferences panes for clues. When I got the the Accounts pane, I got an error box saying "Preferences Error - Could not load Accounts preferences pane". Hmm.. I checked the system log and found this:

    Code:
    2011-04-25 19.16.50	System Preferences[278]	[NSPrefPaneBundle instantiatePrefPaneObject] (/System/Library/PreferencePanes/Accounts.prefPane): principalClass is nil.
    
    Does anyone know what causes this error? I started to suspect I needed to repair disk permissions or I had a bad SSD, so I started Disk Utility.. Only to get a new popup saying "Disk Utility could not be opened because of a problem". What!? I checked the logs again, but it didn't really help. Here's what I found:

    Code:
    2011-04-25 19.08.22	[0x0-0x1f01f].com.apple.DiskUtility[270]	dyld: Symbol not found: _OBJC_CLASS_$_XSAction
    2011-04-25 19.08.22	[0x0-0x1f01f].com.apple.DiskUtility[270]	  Referenced from: /System/Library/PrivateFrameworks/ServerKit.framework/Versions/A/ServerKit
    2011-04-25 19.08.22	[0x0-0x1f01f].com.apple.DiskUtility[270]	  Expected in: /System/Library/PrivateFrameworks/ServerFoundation.framework/Versions/A/ServerFoundation
    2011-04-25 19.08.22	[0x0-0x1f01f].com.apple.DiskUtility[270]	 in /System/Library/PrivateFrameworks/ServerKit.framework/Versions/A/ServerKit
    2011-04-25 19.08.22	com.apple.launchd.peruser.501[90]	([0x0-0x1f01f].com.apple.DiskUtility[270]) Job appears to have crashed: Trace/BPT trap
    2011-04-25 19.08.23	ReportCrash[272]	Saved crash report for Disk Utility[270] version 11.5.2 (298.4) to /Users/erik/Library/Logs/DiagnosticReports/Disk Utility_2011-04-25-190823_MacBook-Air.crash
    
    I checked the app crashlog too, but it said the same thing. I'm starting to think the SSD drive is bad, but I can't check it properly without Disk Utility, that I can't start. I also tried copying the Disk Utility app from another computer to a new folder on the Air, but it still won't run. Does anyone have any idea what I could do next? I have no idea :)

    I've rebooted the Air with "D" pressed and ran the hardware diagnostic, but it didn't report any errors.

    Any help appreciated!
     
  2. Stingray454 thread starter macrumors 6502a

    Joined:
    Sep 22, 2009
    #2
    Ok, so here's what happened..

    I checked everything I could think of - the files accessed when I tried to start certain programs, their size/date/permissions and such, to see if I had any missing files or similar. I came up empty with that.

    Then I booted from my USB restore disk and used Disk Utility from the menu there. I did Repair Disk (no errors) and Repair Permissions (a few things changed). After reboot, the problem was still there though.

    Then I tried re-installing OS X from the USB drive. After it got about half way the installtion stopped :(. It had a message about not beeing able to write some system files, and "Reboot to try again". So I did just that. The second time, the installation finished.

    After the installation, the previous problems were fixed. However, I'm still not sure the SSD is ok in my air - how come more and more programs stopped working before the re-install? And how come the install itself failed once, and then worked? I ran Disk Utility and Disk Warrior, but neither report any problems now. Is there any other way to make some low-level check of your disk?

    I guess my only option is to run it for a while and see if the problems comes back with time..
     

Share This Page