Can't stop iPhoto opening in Yosemite

Discussion in 'OS X Yosemite (10.10)' started by inscrewtable, Oct 17, 2014.

  1. inscrewtable macrumors 65816

    inscrewtable

    Joined:
    Oct 9, 2010
    Location:
    Australia
    #1
    Not sure if this is a bug or if I have missed something. Just upgraded to Yosemite, not a clean install so all my old settings remain but when I put an SD card in my mac, iPhoto keeps opening, I have checked the prefs and the box that says "connecting camera opens" says "no application.

    I've tried trashing the prefs but that has not helped.
     
  2. bucksaddle macrumors 6502

    Joined:
    Dec 4, 2008
    Location:
    UK
    #2
    I had the same issue with a connected iPhone and found that I had to change the default setting in Image Capture even though iPhoto was set to "no application". I guess this is a bug somewhere as setting the preference in iPhoto or Image Capture should make it stick in the other app.
     
  3. stewacide macrumors regular

    Joined:
    Jan 6, 2002
    #3
    Same problem with my iPod Touch (5G). Despite telling it not to open in the iPhoto preferences, every time I connect the iPod iPhoto opens.
     
  4. inscrewtable thread starter macrumors 65816

    inscrewtable

    Joined:
    Oct 9, 2010
    Location:
    Australia
    #4
    I did check image capture but there was no 'preferences' listed. But after reading your post I went back into image capture and I finally discovered that first I need to insert an SD card with images on it, then and only then a little arrow appears in the bottom left corner where I can change it to 'no application'.

    Solved.
     
  5. Pow! macrumors member

    Pow!

    Joined:
    Oct 17, 2014
    Location:
    Toronto
    #5
    iPhoto->Preferences->Connecting camera opens: No application

    You can do it in Image Capture, but it won't stick for new cameras or memory cards etc. If you set it in iPhoto it works for all present and future devices.
     

Share This Page