Can't Stream to ATV Anymore

Discussion in 'Apple TV and Home Theater' started by marcusgee, Sep 19, 2008.

  1. marcusgee macrumors newbie

    marcusgee

    Joined:
    Apr 18, 2008
    #1
    This is a strange one... I store my mostly Handbrake-ripped video files on a 500GB Time Capsule, using my Powerbook to run iTunes and stream wirelessly to my ATV. The setup worked like a charm until recently, when I noticed I couldn't stream movies anymore. I get the dreaded "Selected video could not be played, format not recognized" error.

    I can play movies from the Time Capsule on my Powerbook just fine, and can browse files wirelessly with no problem--so it doesn't appear to be a connectivity issue. Synced movies also play just fine, so the format is good. What's frustrating is that I'm not exactly sure when this started happening. It could have been after the ATV 2.1 update or after I installed iTunes 8.

    Anybody else experienced this issue? I'm at a loss.
     
  2. Cave Man macrumors 604

    Cave Man

    #2
    I've had this a few times and unplugging the ATV seemed to resolve it. Haven't seen it in several months, though.

    Apple really needs a stability update for the ATV, as far as I'm concerned. Especially.....the.....sluggggish.....remote.....issue.....
     
  3. marcusgee thread starter macrumors newbie

    marcusgee

    Joined:
    Apr 18, 2008
    #3
    Rebooting the ATV didn't solve the problem, I'm afraid. I also discovered that I have the same problem even when I'm wired into the Time Capsule--so I'm really beginning to suspect iTunes 8.
     
  4. tom1971 macrumors 6502a

    Joined:
    May 15, 2007
    #4
    I have no problem with iTunes 8.
    do a factory restore. This will most likely solve your problem.
     
  5. dml macrumors newbie

    Joined:
    Feb 12, 2008
    #5
    There have been a number of streaming issues with AppleTV (documented in this forum and elsewhere) since the iTunes 8 update.

    As far as I know, these issues remain to be solved. Factory restore will probably not help.
     
  6. marcusgee thread starter macrumors newbie

    marcusgee

    Joined:
    Apr 18, 2008
    #6
    To top it all off, it seems that I can't sync either. I just tried syncing "It's the Great Pumkin, Charlie Brown" the other day for my kids, and it didn't work over the wire or by wireless. I'm going to try syncing directly from my Powerbook's HD to see if iTunes 8 is having an attitude with Time Capsule. I'll report in with the results when I'm done.

    As I had no trouble with this before the upgrade, it's definitely got to be related to iTunes 8.
     
  7. marcusgee thread starter macrumors newbie

    marcusgee

    Joined:
    Apr 18, 2008
    #7
    Okay, my experiments have confirmed the following:

    --I can sync and stream a movie if it's stored on my Powerbook HD.
    --I can sync and stream a movie if it's stored on my USB hard drive.
    --Sync and stream DO NOT work from movies stored on Time Capsule, wired or wirelessly.

    I'm going to try and add a new movie to my Time Capsule via iTunes 8 and see if that makes a difference. If it does, then I should only have to re-add those movies to my library from Time Capsule. I'll post the results when I know!
     
  8. TyWahn macrumors 6502

    TyWahn

    Joined:
    Oct 25, 2003
    #8
    no show

    I can't get my ATV to even show up in itunes since upgrading to 8 this afternoon.
     
  9. marcusgee thread starter macrumors newbie

    marcusgee

    Joined:
    Apr 18, 2008
    #9
    I never had any issues wth the ATV showing up in iTunes--but I did confirm that by recopying a movie to Time Capsule in a new folder, I was able to sync and stream normally. So basically the drill is: if you're experiencing the same problem, recopy your entire movie library to the Time Capsule and you should be okay. Just to be safe, I'd put it into a different named folder and then reimport into iTunes. Of course, this had the effect of deleting all the movies I had synced to the ATV, so I had to redo that as well. It's a pain in the butt, but now it works.

    Just another reason why you should always keep a second copy of your movies on a backup hard drive!
     
  10. legacyb4 macrumors 6502

    Joined:
    Aug 13, 2002
    Location:
    Vancouver, BC
    #10
    Helped a friend set up his iMac, Macbook, Time Capsule (serving as a bridge to his existing router (needed for his ISP IPTV setup), and AppleTV.

    Everything went smoothly except for that iTunes 8 on either Mac won't recognize the aTV. The aTV itself is wirelessly connected to the network (streams YouTube, shows Flickr, and can accept streamed iTunes music) but isn't recognized in iTunes under the Apple TV menu as being connected or available to connect to iTunes yet it shows as an audio output device in the drop down menu (AirTunes).

    Tried the various reboots, etc. but nothing seems to change.

    Any ideas?

    Cheers.

     
  11. JAWWC macrumors regular

    Joined:
    Jun 1, 2008
    #11
    I've had the error before when I tried to stream, and the way I found out to solve it was not to copy all of the files but simply delete them out of iTunes and re import them all. Worked fine without copying the files.
     
  12. marcusgee thread starter macrumors newbie

    marcusgee

    Joined:
    Apr 18, 2008
    #12
    Looks like Apple just released iTunes 8.01. Hopefully among the bug fixes is a fix for this problem and the one I was having. Give it a shot and let us know what happens!
     

Share This Page