Can't sync music from iTunes to my iPhone 5S

Discussion in 'iPhone Tips, Help and Troubleshooting' started by AVR2, Apr 10, 2015.

  1. AVR2, Apr 10, 2015
    Last edited: Apr 11, 2015

    AVR2 macrumors 6502

    Joined:
    Jan 16, 2006
    #1
    I have an iPhone 5S on iOS 8.3, managed using iTunes 11.4 on my 2006 MBP running 10.6.8.

    Simply put, how do I get music onto it from iTunes? I synced music to it last summer when I first got it, but I can't remember what I did, and now I can't get it to work. I'm used to just dragging songs from the library over to the device in the sidebar, but that's not working. Am I supposed to create a playlist and sync that?

    EDIT - I've just reset it to factory settings and restored a backup, and I still can't find a way to get any music from my iTunes library on my MBP onto the phone. My purchased music is showing up on the phone as being available to download from iCloud, but that's all.

    I've tried going to individual tracks, clicking the right-pointing arrow and choosing "Add to>Device>iPhone", but iTunes just sits there for a while saying "Preparing to update" and then nothing happens. The track doesn't get synced to the phone and I get no message telling me of any kind of failure.

    Is the problem that I'm still on iTunes 11.4? It's the most recent version that will still run on 10.6.8 AFAIK - and I can't update my OS any further because I only have a Core Duo CPU, not Core 2 Duo.
     
  2. adamhenry macrumors 65816

    adamhenry

    Joined:
    Jan 1, 2015
    Location:
    On the Beach
    #2
    I use playlists to organize and sync my music. If you go to the page that shows your music after attaching your phone, there are options to sync playlists, albums, and artists. I think there is even an option to sync all music. Dragging and dropping seems like a hard way to do things.
     
  3. AVR2, Apr 13, 2015
    Last edited: Apr 13, 2015

    AVR2 thread starter macrumors 6502

    Joined:
    Jan 16, 2006
    #3
    Well, it's actually very easy. But my issue is, it doesn't work for my iPhone. It works fine for my iPods.

    Should it work on my iPhone?

    EDIT - I've just tried it using iTunes 12.1 on my iMac at work, and dragging and dropping works perfectly. I guess I'll just have to put it down to incompatibility between iTunes 11.4 (and/or Snow Leopard) and the iPhone 5S.

    EDIT EDIT - this looks like it's my problem. I'll check it out at home later.
     
  4. AVR2 thread starter macrumors 6502

    Joined:
    Jan 16, 2006
    #4
    Just in case it helps somebody, the problem was indeed with iTunes 11.4. By deleting the .kext file specified in the link I give above, and then re-installing 11.4, I've now got my MBP playing nicely with my iPhone again.
     

Share This Page