Can't sync photos to iPad 2017

Discussion in 'iPad Tips, Help and Troubleshooting' started by FO320, May 29, 2018.

  1. FO320 macrumors newbie

    Joined:
    May 29, 2018
    #1
    Hi everyone,

    so after waiting patiently for several updates of itunes and my ipad 2017 (non-pro), I am still unable to sync photos from iTunes to my iPad. It just won't work, and that in many different ways:
    Either:
    - The sync goes through, but there are no photos to be seen on my iPad at all (but they are on the device, the memory is taken up and if I check with another program such as anytrans, they are there).
    --> Is there a way to kind of rebuild the photo index?
    - The sync does not go through and iTunes reports that there was an "internal device error"

    I tried restoring it from scratch several times, I tried syncing from the rather dreadful mac photos app instead of just images from a folder as I usually do and I tried doing it from a windows machine and from my MacBook Pro.

    Does anyone have a good idea on what I could to?

    Thanks a lot...
     
  2. flaubert macrumors regular

    Joined:
    Jun 16, 2015
    #2
    I assume that you're running latest firmware (11.3 or 11.4). When you say you've restored it several times, was that a restore of data, or the full firmware restore to factory condition? My guess is that whatever you've been doing, it probably involved a restore of data from backup at some point. This seems like one of those situations where something is corrupt on the device and in the data backup, and the only way out of the thicket is to do the full wipe and restore of firmware, and then not do a restore of data, since that is where the corruption is likely hiding. Instead, after the restore of firmware when it presents you with the choice of restore from a backup or set up as a new device, you go with setup as new device. It's a pain, I know, to have to manually select/download all your apps and configure your accounts, but it is probably the only chance you have to get to a fully working iPad experience.
     
  3. FO320 thread starter macrumors newbie

    Joined:
    May 29, 2018
    #3
    Yes I am running 11.4. You know, that was exactly what I thought and therefore I tried both methods - unfortunately to no avail. I am really frustrated with this...
     
  4. flaubert macrumors regular

    Joined:
    Jun 16, 2015
    #4
    Is iCloud photo library involved (turned on), either in Photos on the Mac or Settings on the iPad? Because that would explain why the space was reserved on the device, and perhaps just not yet downloaded to show up??
     
  5. FO320 thread starter macrumors newbie

    Joined:
    May 29, 2018

Share This Page