Can't sync photos to iPhone, iPad

Discussion in 'iPhone' started by benhollberg, Sep 2, 2011.

  1. benhollberg macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #1
    Recently I took some pictures on my iPhone and then transferred them to iPhoto on my Mac. After syncing again the photos will not transfer to my iPhone. The photos are in iPhoto and they were taken with my iPhone. I did nothing different than I usually do when syncing. In addition, the photos will not go transfer to my iPad. I know that other newer pictures will sync just perfect now because I just tried and it works fine.

    This is the window that comes up when syncing:
    [​IMG]

    If anyone has any suggestions or theories on how to fix this please help. Or if anyone has had this happen to them before as well, I have never heard of this happening before.
     
  2. wrinkster22 macrumors 68030

    wrinkster22

    Joined:
    Jun 11, 2011
    Location:
    Toronto
  3. benhollberg thread starter macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #3
    I thought all pictures are optimized for the device upon syncing? Also I took the picture with the same phone so it was on it before.
     
  4. Gandalf! macrumors member

    Joined:
    Jun 15, 2005
    #4
    This happened to me

    Very frustrating. My issue was with the thumbnail images. Try this:

    Go to the pictures folder in your home folder.

    Right click on the iPhone Library icon and click "Show Package Contents"

    Drag the "iPod Photo Cache" to the trash (it will be recreated when you sync your phone)

    Try syncing again
     
  5. Gandalf! macrumors member

    Joined:
    Jun 15, 2005
  6. benhollberg thread starter macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #6
    I haven't had the chance to try it yet. I will for sure later this week and let you know. Thanks for the suggestion.
     
  7. andylyon macrumors 6502a

    andylyon

    Joined:
    Jul 23, 2008
    Location:
    London
    #7
    I'm also having this problem and am also going to try your suggestion as soon as my iPhoto DB ha finished being rebuilt.

    What I don't understand is that these photos that are not syncing now have been syncing fine for the last two years.

    I reinstalled Lion and then reinstalled the latest version of iOS, everything else moved back on to my iPhone fine except for photos. Only around 200 of the 2500 worked upon syncing.

    Very strange but I will try your suggestion.
     
  8. andylyon macrumors 6502a

    andylyon

    Joined:
    Jul 23, 2008
    Location:
    London
    #8
    I can confirm i've just tried this and it didn't work :(

    Any other suggestions people?
     
  9. benhollberg thread starter macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #9
    Do you get the window that I posted in the first post?
     
  10. andylyon macrumors 6502a

    andylyon

    Joined:
    Jul 23, 2008
    Location:
    London
    #10
    Yeah the same (diff image name thought of course) and sorry for sort of hijacking you're thread but the more people asking for help the better!
     
  11. benhollberg thread starter macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #11
    Your not hijacking, you have the same problem so hopefully we both can find the same solution.
     
  12. Krafty macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
  13. andylyon macrumors 6502a

    andylyon

    Joined:
    Jul 23, 2008
    Location:
    London
    #13
    Nope i've got a good 2.5GB free.
     
  14. benhollberg thread starter macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #14
    Same, I have 1.9GB free. Also it couldn't be that because more recent photos I have taken will sync.
     
  15. andylyon macrumors 6502a

    andylyon

    Joined:
    Jul 23, 2008
    Location:
    London
    #15
    I do think it has something to do with iPhoto's library as after rebuilding it using the cmd+opt way it now syncs many more of the photos, but still not all.
     
  16. Gandalf! macrumors member

    Joined:
    Jun 15, 2005
    #16
    I'm sorry it didn't work. When I was researching this for me, I also read to try removing all music and videos from the sync first, then syncing the images, then going back and adding back the music and videos. I didn't need to try that step for me, but it's worth a shot.
     
  17. benhollberg thread starter macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #17
    I think I'll give that a try next time I go to sync.
     
  18. andylyon macrumors 6502a

    andylyon

    Joined:
    Jul 23, 2008
    Location:
    London
    #18
    Hi all, just letting you know that after a couple of days I have finally got my syncing working as it should. However I can't give you a perfect solution as I don't know how this sorted itself out. One thing I did do was rebuild my iPhone library using all the available options several times - so it looked like a corrupted library was the problem.

    Thanks for all the help and OP I recommend repairing your library 3/4 times.
     
  19. benhollberg thread starter macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #19
    I stopped syncing music and photos and then re-added the music. I had about 3GB left so I readied the photos. Still those same two photos didn't sync. This was on my iPhone, haven't tried the iPad yet.
     

Share This Page