Can't sync with itunes after jailbreak - help!

Discussion in 'Jailbreaks and iOS Hacks' started by Ezdezat, Dec 13, 2010.

  1. Ezdezat macrumors newbie

    Joined:
    Dec 13, 2010
    #1
    Hi Folks,

    Am new to the site (and iphone!). Looking for help!

    I have an iphone 4, running os 4.1. I wanted to sim unlock it so i could use one of those dual sim adaptors & put my standard work sim in also.

    So i did a jailbreak using Limera1n, and tried to unlock using ultrasn0w. After attempting the unlock, the phone came back on & displayed the 'connect to itunes' icon, upon which itunes informed me there was an error and the phone needed to be restored. I had to do this twice, and the phone eventually came back on (after an hour or so of panic that i'd just broke my new iphone!), with everything still intact.

    Not sure if the unlock worked as i need to try another microsim, everything else is still there & the jailbreak worked.

    Anyway, i cannot sync with itunes. I've tried everything, except doing a factory reset of the iphone, which i assume means i'll lose my jailbreak & my apps! Is this my only option?

    Have tried re-installing itunes etc etc...

    Thanks!
     
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    OK..so 2 things, first if you restore to 4.1 using itunes, them you upgraded your baseband to the version that is currently no unlockable, so you are out of luck there (well you can unlock it upgrading to the iPads BB, but you may not want to do that right now).

    Second, now you know that you unlock is not going to work, we need for info as exactly what is going wrong with iTunes? you get an error? Iphone doesn't show up? you get the USB device connected sound? tell us more.

    You can try restoring to 4.1 again, (since you said you did it twice, I am going to assume that your SHSHs are saved). and them Jailbreak using Limera1n, or Greenpois0n. (or you can use a custom firmware using pwnage tool). don't try to unlock again, since you can't right now. That may solve some of the issues.
     
  3. Ezdezat thread starter macrumors newbie

    Joined:
    Dec 13, 2010
    #3
    Hi,

    My baseband is 02.10.04, which i see from some other threads is not unlockable yet, so i suppose i can forget about that! So now all i want to do really is be able to sync, i don't mind if my jailbreak disappears as i'll wait now until an unlock is available for my OS.

    itunes just doesn't detect my iphone at all. So you reckon if i restore again this should work? Would i lose my apps?

    Thanks,
     
  4. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #4
    You AppStore are in iTunes, no matter how many times your restore, you can get our app backs, settings and gave saved you need an itunes backups, depending on when was the last time you sync you can get all back.

    It is weird that itunes doesn't see it, do you get the USB device plug sound?
    can you try another machine?
    can you try another USB cable?
    did u try rebooting the machine, and hard reboot your phone (Hold Power + home bottom)

    also try re-installing iTunes, sometime it gets funny
     
  5. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #5
    Restore your phone in DFU mode. You won’t lose your apps, since they’re synced with iTunes.
     
  6. Ezdezat thread starter macrumors newbie

    Joined:
    Dec 13, 2010
    #6
    Hi All,

    Thanks for your replies, have been away for a few days but still haven't solved the problem.

    Have tried restoring in DFU mode, the phone restores but when finished itunes still doesn't detect it. Have tried re-installing itunes several times, re-booting both PC & phone. I know the USB port & cable works as itunes detects the phone when i put it DFU mode, but like i say restores it, and still doesn't detect it.

    Strangely though, after i restore from DFU, everything is as is on the phone, should it not have gone back to factory settings? Am i doing something wrong here? Am following all of the instructions!

    I don't care about losing all my data at this stage, i can start from scratch once i can sync!

    Thanks!
     
  7. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #7
    Just in case: you need to have the original sim card inside the phone for it to activate after a restore to get the phone working...

    If you really did do a DFU and restore AS NEW w/out using backups and the phone is still not being recognized in iTunes then take it to the :apple: store
     
  8. Ezdezat thread starter macrumors newbie

    Joined:
    Dec 13, 2010
    #8
    Hi Carlanga,

    Yes original sim is inside. Problem is the phone won't restore. I press & hold the Home button, then switch the phone on. It displays the connect to itunes symbol, so i do that, itunes says it detects a phone in recovery mode & i click the restore button in itunes. It says contacting apple server, then downloads for about 10 mins. Phone comes back on when finished but is not restored to factory settings. So....i have the problem that i cannot get rid of Cydia so are the Apple store people not gonna be looking at me a bit funny?!
     
  9. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #9
    you are not in DFU Mode, DFU Mode the screen remains black
    Instructions: http://www.iclarified.com/entry/index.php?enid=1034
    Don't use backups and reinstall as NEW...
     
  10. Ezdezat thread starter macrumors newbie

    Joined:
    Dec 13, 2010
    #10
    Thanks for the advice, you were correct i wasn't in DFU.

    So i tried that, got the black screen & did a restore, got error 1013, the phone went back in recovery and is stuck there! Keep getting error 1013, have tried restoring at least 10 times, also tried numerous different software to try kick it back out (tinyumbrella / iRecovery etc), nothing is working :(
     

Share This Page