Can't traceroute on Mac?

Discussion in 'Mac Basics and Help' started by Collected, Jan 8, 2011.

  1. Collected macrumors regular

    Joined:
    Apr 8, 2010
    #1
    Very odd problem..

    Today I felt access to a particular website was rather slow, so I decided to do a traceroute to the site in question to see if my ISP had a routing issue.

    However all I get is * * * on every hop including the 1st one. It doesn't get anywhere at all. Just time out, time out, time out.

    So I tried ping.. ping works fine. It resolves the DNS, and the ping is returned with no problems. I can load plenty of websites, including this one.

    So I fired up my windows box that is on the same network, same router.. traceroute works fine to the same sites.

    What is even more strange is I can traceroute over a VPN to my machine at work.. but traceroutes to sites that work on my windows box fail to work on my mac.

    Any suggestions? Thank you. Probably something simple but I can't work out what's causing it.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    It's got to be a networking setting on your Mac somewhere. First thing I'd check is the firewall settings. Then, make sure everything looks right in the Network pane of System Preferences.
     
  3. MacTribe macrumors member

    MacTribe

    Joined:
    Dec 26, 2010
    Location:
    London
    #3
    Try set up a 2nd test account on your Mac then traceroute from there. Also make sure you try in both 'network utility' and 'terminal' and lastly make sure you've done all the obvious things like restarting the machine, router, switches etc and checked you have the correct network settings under 'System Preferences'
     
  4. Collected thread starter macrumors regular

    Joined:
    Apr 8, 2010
    #4
    Checked my network settings. It's DHCP over wireless so no real configuration has ever been done. It did it itself when I connected to my wireless router. Firewall is turned off. It does the same thing if I run the traceroute from the network utility and terminal. Rebooted router and mac. I've not setup a new user tho, that's the only thing left to try.

    Here is an example:

    traceroute to www.macrumors.com (74.86.132.180), 64 hops max, 52 byte packets
    1 * * *
    2 * * *
    3 * * *

    PING www.macrumors.com (74.86.132.180): 56 data bytes
    64 bytes from 74.86.132.180: icmp_seq=0 ttl=46 time=145.458 ms
    64 bytes from 74.86.132.180: icmp_seq=1 ttl=46 time=142.007 ms
    64 bytes from 74.86.132.180: icmp_seq=2 ttl=46 time=142.298 ms

    So ping works.. but traceroute doesn't want to. Very odd. I'll update if I ever find the cause. :) Thank you for the suggestions.
     
  5. jlg89 macrumors newbie

    Joined:
    Jan 8, 2011
    #5
    Possible solution

    Usually, when pings work but traceroutes don't, it's because some or all ICMP traffic is being blocked somewhere. Be sure your local firewall is configured to at least allow "ICMP required types."
     
  6. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #6
    I bet IMCP is blocked by his firewall or his/her's Internet router.
     
  7. Eric Lee, May 31, 2013
    Last edited: May 31, 2013

    Eric Lee macrumors newbie

    Joined:
    May 24, 2013
    #7
    Hi,
    Under Windows traceroute uses ICMP while under Unix traceroute uses UDP. If something is filtering UDP packets, the Window traceroute will work when a Unix traceroute won't. Also note that ping uses TCP so there's no connection to traceroute not working. Modern firewalls will kill random UDP traffic (not IMCP!), since it got abused in the past (Windows botnets come to mind).

    This thread is somewhat old but if you run into this kind of problem:

    Open terminal and copy&paste the following command and hit enter to see if a ICMP tracert works:
    Code:
    traceroute -P icmp 217.72.205.202
    Best regards,
    Eric
     

Share This Page