Can't turn off autocorrect in Messages

Discussion in 'OS X El Capitan (10.11)' started by mlsusa, Oct 3, 2015.

  1. mlsusa macrumors regular

    Joined:
    Sep 17, 2012
    #1
    As the subject says, Messages annoyingly continues to autocorrect even though I've turned it off (System Preferences -> Keyboard -> Text -> Correct spelling automatically is turned off). Mail, Calendar, and a few other stock apps seem to honor the setting.

    This happened with the El Capitan beta all the way to the GM, the official release, and 10.11.1. My iMac which is still on Yosemite is not autocorrecting in any app.

    I didn't see anything related in searches in these forums. Google search doesn't turn up anything either. Just articles on how to turn autocorrect on and off.

    Anyone else seeing this? Any ideas what I can try? Maybe some settings only available through Terminal commands?

    Thanks in advance for any tips and suggestions.
     
  2. mlsusa thread starter macrumors regular

    Joined:
    Sep 17, 2012
    #2
    Got the answer through a chat with Apple Support. In hindsight it should have been obvious.

    In Messages go to the Edit Menu. Under Spelling and Grammar I found that Correct Spelling Automatically was still turned on. It should have been turned off by the general settings change but that didn't happen.
     

Share This Page