Can't turn off badge icon with twitter app update

Discussion in 'iOS 8' started by robmadden1, Sep 18, 2014.

  1. robmadden1, Sep 18, 2014
    Last edited: Sep 18, 2014

    robmadden1 macrumors member

    Jun 3, 2014
    the toggle is totally missing from the new version with interactive notifications. Does anyone else have this ame issue?
  2. C DM macrumors Sandy Bridge

    Oct 17, 2011
    Interesting, I don't see it in Notifications settings for Twitter either.
  3. robmadden1 thread starter macrumors member

    Jun 3, 2014
    I hate not being able to turn it off. I hate seeing badge icons.
  4. TonyC28 macrumors 65816


    Aug 15, 2009
    This has to be a glitch with the Twitter app. I get a notification badge every time I close the app, even thought there's nothing new to see.
  5. Grayburn macrumors 68000


    Jul 12, 2010
    London, England
    I have the same "issue" but it's most probably meant to be like that.

    One problem i do have is that Twitter notifications dont show up in notification center even when set up to do so.
  6. Lukkee24 macrumors 6502a

    Sep 20, 2011
    I still have this problem too (iPhone 5s; iOS 8.1) and it's incredibly annoying. I'll open the app and the badge app icon will go, but then within two seconds of closing the app the (1) is back again! No option to turn off the badge app icon in notification settings, and reinstalling the app only fixes it temporarily.
  7. AppleChic76 macrumors 6502a


    Sep 13, 2014
    I'm having this problem with Facebook after the update. Hating it!! #
  8. Weiser878 macrumors regular


    Sep 9, 2009
    Not only can you not turn it off, but as others have said it comes on when you close the app (its telling you there are new things in you feed.
    You have to close the app, wait a few seconds, then double click and flip it up to avoid the badge telling you there are new tweets.
    It does suck. I keep badges turned off for everything except texts because that's the only thing it matters if I miss (especially since I don't ever answer phone calls and don't have voicemail set up.)

Share This Page