Can't turn off Sleep Schedule on Macbook Pro!

Phill-art

macrumors newbie
Original poster
Jan 29, 2013
18
1
I've tried trashing the com.apple.PowerManagement.plist and the com.apple.AutoWake.plist and restarting the computer right after, multiple times. Yet it still brings up a message that says something like 'This computer is scheduled to sleep at 8:40 and will go to sleep in 10 minutes if nothing is done'. I have NO schedule for it to sleep!!! And it's always around 8:40 pm, sometimes it's a few minutes after or before that time (so I can't even set up a counter wake up schedule for it because the time varies).

When it goes to sleep, it disconnects me from a game I'm playing (that takes up the whole screen and can't be minimized) and it pisses me off. Please help!!!!
 

GGJstudios

macrumors Westmere
May 16, 2008
44,360
701
I've tried trashing the com.apple.PowerManagement.plist and the com.apple.AutoWake.plist and restarting the computer right after, multiple times. Yet it still brings up a message that says something like 'This computer is scheduled to sleep at 8:40 and will go to sleep in 10 minutes if nothing is done'.
You mention deleting .plist files, but you didn't specifically say if you tried the normal route of going to System Preferences > Energy Saver > Schedule and unchecking the boxes there.

Caffeine will temporarily override your energy saver settings and keep your Mac awake with a click on the Menu Bar icon. Another click turns it off.

To keep your Mac notebook awake with the lid closed, use InsomniaX or InsomniaT (rebuild for SL) (fix for 2011 MPBs)

NoSleep also keeps your Mac notebook awake when you close the lid.
 

Phill-art

macrumors newbie
Original poster
Jan 29, 2013
18
1
Thanks for the links, I'll try them. As for the boxes being unchecked, they definitely are. : /
 

Phill-art

macrumors newbie
Original poster
Jan 29, 2013
18
1
You mention deleting .plist files, but you didn't specifically say if you tried the normal route of going to System Preferences > Energy Saver > Schedule and unchecking the boxes there.

Caffeine will temporarily override your energy saver settings and keep your Mac awake with a click on the Menu Bar icon. Another click turns it off.

To keep your Mac notebook awake with the lid closed, use InsomniaX or InsomniaT (rebuild for SL) (fix for 2011 MPBs)

NoSleep also keeps your Mac notebook awake when you close the lid.
I had Caffeine running, and the sleep schedule message still popped up! I Also tried activating Caffeine after the message popped up, to see if it would counter it. Didn't work.

I read somewhere this could have something to do with the logic board of the computer... Am I mistaken? If so, is this a hardware problem and something that can't be fixed without taking it to Apple?
 

chown33

Moderator
Staff member
Aug 9, 2009
8,356
4,333
Gourd City
I read somewhere this could have something to do with the logic board of the computer... Am I mistaken? If so, is this a hardware problem and something that can't be fixed without taking it to Apple?
It may be broken hardware. Unless you're handy with electronics, repairs should be done by Apple, or certified tech.

Did you run the Hardware Test?
http://support.apple.com/kb/HT1509

Did you try a Safe Boot?
http://support.apple.com/kb/HT1564

If a faulty extension or driver is triggering the sleep, then Safe Boot should prevent it from happening. Restarting in Normal Mode (i.e. not Safe Mode) would allow the scheduling again, if you took no steps to identify or remove the faulty driver. That is, Safe Boot is a diagnostic tool, not a repair tool.
 

Phill-art

macrumors newbie
Original poster
Jan 29, 2013
18
1
I tried running a normal and extended hardware test. There were NO found issues. Booting it in safemode wouldn't do me any good because of its limitations.

Is there anyone in the mac world that has any idea what the heck is going on? So now my computer has been wanting to go to sleep around 10:00pm, just tonight it was closer to 11:00pm. And it's not everyday it does this....
 

Duffie

macrumors newbie
Mar 4, 2014
1
0
Turn off Sleep Schedule on Macbook Pro

Hi Phill-art, any solution to this problem? I have the same, on a brand new MBP running Mavericks, after a clean install. Diagnostics returned no problem.
 

Phill-art

macrumors newbie
Original poster
Jan 29, 2013
18
1
It fixed itself apparently... I had a theory it was something to do with my back up program called iDrive (the automatic sleep time glitch happened around when iDrive was scheduled to back up my files. I still use iDrive, but I changed the schedule when it backs up, then I noticed the problem happening less and less until it stopped.
 
  • Like
Reactions: ctwardy

Elfsinger

macrumors newbie
Jan 17, 2015
2
2
Hiya, just to say that I'm getting the same situation.
("This computer has been scheduled to go to sleep automatically")
Thanks for your post as it confirms something I've suspected for a while. I wondered if this prob might be down to iDrive because it's only done it since i had started using iDrive. It's driving me nuts too.
Actually, there is a lot about iDrive that drives me nuts and I won't be renewing. Seemed like a good idea at the time but it takes SO MUCH bandwidth to update, takes ages to upload stuff so is working all the time and chokes up the wifi for my husband (trying to play WOW MMO on his computer) as well as trying to put my computer to sleep automatically. Conversely their customer service is awesome but Back to HD drives for me.
 
  • Like
Reactions: ctwardy

dajatsu

macrumors newbie
Jun 1, 2013
2
1
Hiya, just to say that I'm getting the same situation.
("This computer has been scheduled to go to sleep automatically")
Thanks for your post as it confirms something I've suspected for a while. I wondered if this prob might be down to iDrive because it's only done it since i had started using iDrive. It's driving me nuts too.
Actually, there is a lot about iDrive that drives me nuts and I won't be renewing. Seemed like a good idea at the time but it takes SO MUCH bandwidth to update, takes ages to upload stuff so is working all the time and chokes up the wifi for my husband (trying to play WOW MMO on his computer) as well as trying to put my computer to sleep automatically. Conversely their customer service is awesome but Back to HD drives for me.
[doublepost=1504708199][/doublepost]Thanks!!! I hadn't made the connection, but my trouble also started when I started using iDrive on my MacBook Air. I disabled it and I too will not be renewing (got a cheap first year special). It's back up ability is really slow. The only reason I have a complete back up with iDrive is that I took advantage of their free mail in (once a year) backup. I was only using it as a second backup. My TimeMachine is fine.
 
  • Like
Reactions: ctwardy

micromac_fanatik

macrumors newbie
Sep 24, 2017
1
1
Same problem for me!

I have macs from 2007 and never have been seen these kind of messages before, only now in Sierra, on a MBP 2012. I thought that is some quirk in Mac, but reading and then correlating, it's sure that's coming from iDrive.

I installed iDrive, on Sierra OS, not long ago (now I realize that in same time these annoying going to sleep messages started). Same, I got the iDrive w/ discount and as you, encountered the limitations of this backup system.

By the way, I made myself an account here, just to thank you guys for you brought back the sanity between me and my Mac :)
 
  • Like
Reactions: ctwardy

hobowankenobi

macrumors 6502a
Aug 27, 2015
980
261
on the land line mr. smith.
It fixed itself apparently... I had a theory it was something to do with my back up program called iDrive (the automatic sleep time glitch happened around when iDrive was scheduled to back up my files. I still use iDrive, but I changed the schedule when it backs up, then I noticed the problem happening less and less until it stopped.
Ah, iDrive. Yes, same here. Thanks!

I want to like iDrive...but in testing about a year ago, I found lots of strangeness and general bugginess. If they ever get their Mac client working well, I will go back.

Will add this to the list. :(