Can't turn Wifi On

Discussion in 'macOS Sierra (10.12)' started by jww062, Oct 20, 2016.

  1. jww062 macrumors member

    Joined:
    Dec 1, 2012
    #1
    Today, I suddenly cannot turn on my Wifi connection.

    If I go to the menu and select Turn Wifi On, it just stays off. It doesn't turn on -- the menu even still says Turn Wifi On.

    Same result if I go to Network in System Preferences and hit the Turn On button for Wifi.

    If I attempt to use the assistant or diagnostics under assist me, both have a prompt that says Turn Wifi On during the process. Even if I tell it to turn wifi on, it advances to the next screen (where it can't find any networks), but Wifi is still off.

    Any assistance that can be provided would be helpful. The Wifi device is still listed as en0 if I run ipconfig in a terminal, as well as under About This Mac > System Report under the Wifi section. I also tried the networksetup command to enable it and that did not work, either.

    I also did try rebooting, just for fun -- no dice.

    Thank you in advance for any insight/tips. All the searching I have done has turned up fruitless so far.
    --- Post Merged, Oct 20, 2016 ---
    Also, additional bit: If I reboot my Macbook, it comes on and the icon in the menu bar appears to be a Wifi icon that is enabled but not connected, and if I click it, it gives the option to turn off Wifi. But if I go to System Preferences > Network, it says Wifi is off.
     
  2. psik macrumors 6502

    Joined:
    Aug 21, 2007
    #2
    have you run diagnostic tools such as EtreCheck and TechToolPro?
     
  3. macpro00 macrumors member

    macpro00

    Joined:
    Feb 7, 2016
    #3

    Is anyone else having this problem?
     
  4. jww062 thread starter macrumors member

    Joined:
    Dec 1, 2012
    #4
    Not sure what the issue truly was, but it disappeared when I upgraded to 10.12.1.
     

Share This Page