Can't type Firmware Password (Keyboard not responding)

Discussion in 'Mac Pro' started by X--X, Jan 16, 2016.

  1. X--X macrumors 6502

    Jun 11, 2015

    Today I installed El Capitan on my Mac Pro 2009 and it went fine.

    Just one Problem:
    I want to disable SIP System Integrity Protection to change some default icons.

    When I try to boot into Recovery Mode the Mac asks me for the Firmware Password, but mouse and keyboard are both not responding, I can not type anything.

    I know my Firmware Password but I can't type it in, I'm pulling my hair out here.

    Any help would be very much appreciated.


    I tried unplugging everything but the keyboard. I reset SMC. Didn't help.
  2. cerberusss macrumors 6502a


    Aug 25, 2013
    The Netherlands
  3. X--X thread starter macrumors 6502

    Jun 11, 2015
  4. X--X thread starter macrumors 6502

    Jun 11, 2015
    NVRAM is protected by the firmware password and I can't type that in. We've come full circle.
  5. Thessman macrumors regular

    Dec 8, 2005
  6. Erdbeertorte, Jan 17, 2016
    Last edited: Jan 17, 2016

    Erdbeertorte macrumors demi-goddess

    May 20, 2015
    Are you sure? I never was asked for my firmware password when I did an NVRAM reset.

    You could also just boot OS X normally, mount the Recovery HD and open the folder, then mount BaseSystem.dmg, open the folder Applications, then go to the folder Utilities and just launch the Firmware Utility.

    Maybe you can disable it there. I just tried it to set a firmware password. But it says that non is set when I open it again. I reboot now to see if it worked.

    Edit: Worked, I can now do the same again to change or disable it.
  7. X--X thread starter macrumors 6502

    Jun 11, 2015

Share This Page