Can't type straight single quotes

Discussion in 'OS X El Capitan (10.11)' started by mikethebook, Sep 25, 2016.

  1. mikethebook macrumors member

    Joined:
    May 30, 2010
    #1
    I'm running El Capitan but I think the problem existed when I ran Mavericks too. I can't get the single quote key to type a straight quotation mark. Whether I tick or leave unticked the "smart quotes and dashes" box in Text Preferences the single quote mark comes out curly. Can anyone help me to fix this?
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
  3. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #3
    The general setting in System Preferences does not disable it for all programs, only when that program has not changed the default. Go to the program in question → ‘Edit’ → Substitutions → ‘Smart Quotes’.
     
  4. mikethebook thread starter macrumors member

    Joined:
    May 30, 2010
    #4
    I've not tried it in all apps but the problem exists in all those I've tested and I don't ever recall changing defaults with regard to quotes in any app. The app I want it to work in is a simple abcnotation app called EasyABC. I don't understand your suggestion Kallt because under the Edit menu in EasyABC there is no Substitutions.
     
  5. KALLT macrumors 601

    Joined:
    Sep 23, 2008
  6. mikethebook thread starter macrumors member

    Joined:
    May 30, 2010
  7. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #7
    Wherever you type text, you can right-click. There is also a menu called ‘Substitutions’. Perhaps the app you are using changed the Edit menu.

    Screen Shot 2016-09-25 at 22.45.28.png Screen Shot 2016-09-25 at 22.45.00.png
     
  8. mikethebook thread starter macrumors member

    Joined:
    May 30, 2010
    #8
    Thanks. I understand now. But right-clicking on text doesn't always bring up such a comprehensive menu. I tried with LibreOffice, the word processor I use, without success and as for EasyABC, it came up with a very simple menu with nothing like Substitutions etc.
     
  9. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #9
    The problem likely is that some of your apps have their own autocorrect which overrides the system wide preferences. For instance in LibreOffice, check: Format > Autocorrect > Autocorrect Options...
     
  10. mikethebook thread starter macrumors member

    Joined:
    May 30, 2010
    #10
    That's quite possible but not EasyABC which has very limited options.
     
  11. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #11
    I’ve had a look at this program and I am unable to reproduce the problem. Seems to be working fine on my system. Can you type the following command into a Terminal window and paste the result here?
    Code:
    defaults find quotesubstitution
     
  12. mikethebook thread starter macrumors member

    Joined:
    May 30, 2010
    #12
    I can try to do that but first, to understand fully my problem, run the following in EasyABC and tell me whether the symbol over the second note is a wedge/straight quote or a curly quote. The straight quote comes out fine, as a straight quote, in the example I've sent (just after the ^) but it doesn't appear as such over the note in the music.

    X: 1
    T: Test
    M: 4/4
    L: 1/8
    R: reel
    K: Dmaj
    %%annotationfont Larsen 21
    G2"^'"Bd BAGB |

    Here's what I got from Terminal:
    Found 1 keys in domain 'com.piriform.ccleaner': {
    NSAutomaticQuoteSubstitutionEnabled = 0;
    }
    Found 1 keys in domain 'com.apple.messageshelper.MessageController': {
    SOInputLineSettings = {
    automaticDashSubstitutionEnabled = 0;
    automaticDataDetectionEnabled = 0;
    automaticEmojiSubstitutionEnabledLegacy = 0;
    automaticEmojiSubstitutionEnablediMessage = 1;
    automaticLinkDetectionEnabled = 0;
    automaticQuoteSubstitutionEnabled = 0;
    automaticSpellingCorrectionEnabled = 1;
    automaticTextReplacementEnabled = 1;
    continuousSpellCheckingEnabled = 1;
    grammarCheckingEnabled = 0;
    smartInsertDeleteEnabled = 1;
    };
    }
    Found 1 keys in domain 'Apple Global Domain': {
    NSAutomaticQuoteSubstitutionEnabled = 0;
    }
    Found 1 keys in domain 'com.apple.iBooksX': {
    TSWPAutomaticQuoteSubstitution = 0;
    }
    Mikes-Mac-mini:~ mikewallbridge$
     
  13. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #13
    This sounds like a problem with the program then.
     
  14. mikethebook thread starter macrumors member

    Joined:
    May 30, 2010

Share This Page