Can't Unlock System Preferences

Discussion in 'Mac OS X Lion (10.7)' started by moonchilddave, Jul 31, 2011.

  1. moonchilddave macrumors regular

    Sep 21, 2009
    Anyone else with Lion found that after a while the System Preference panes won't unlock (if you have lock turned on)? That is really bugging me - and the only fix I've found was to reboot the system.
  2. ideal.dreams macrumors 68020


    Jul 19, 2010
  3. BrooklynAl macrumors regular

    Jul 31, 2011
    System Preference

    I am having the same problem; if I close system preferences after I reboot I cannot unlock the locked panels. Though, if I reboot and keep the system preferences open I can lock and unlock all the panels. Tried to delete the respective .plist files but to no avail. Must represent one of the may bugs in Lion.
  4. BrooklynAl macrumors regular

    Jul 31, 2011
    System Preferences

    The solution is simple just delete the folder from the Cache folder i.e. ~/library/Cache/ First close system preferences then delete folder then reboot; worked like a charm--good luck!
  5. reberhardt macrumors newbie

    Aug 8, 2011
    Having the Same problem

    I also cannot unlock any locked system preferences - I enter my password and the system just seems to ignore it. I am sure that I am entering the password correctly.

    As a result, I cannot change the preferences and also cannot do any administrative functions like installing software.

    I have a couple of accounts on my MBP - both are administrators. When I try to switch accounts - I can't do that either. When you enter an incorrect password on this screen, the icon wiggles. I am not getting that. What happens is that the OS tries to move to the next screen and just returns to the switch account screen.

    I tried rebooting and removing the setupcomplete flag to create a new account. Then I could not sign on with any of the three accounts.

    I could do these admin functions a few days ago. I the intervening period, I ran a permissions fix. I am not sure that led to the problem, but am suspicious.

    The Genius Bar person advised me to revert to an earlier Time Machine backup - but the issue of not being able to do admin functions persists.

    Any ideas would be appreciated.
  6. moonchilddave thread starter macrumors regular

    Sep 21, 2009
    Found this on another Apple Discussion thread:

    This may have been my issue - as I also reinstalled the drivers to make the CAC work. Of course, rebooting always fixed it for me, so I guess I'll see if this solution fixes the problem permanently.

    Here's the discussion thread:
  7. Mangeur d'pomme macrumors newbie

    Nov 19, 2011
    Found something !

    Hi everyone, I also have this issue: iMac mid-2010, Intel core i7 - 2,93GHz - 1TB HDD - 256GB SSD - OS X Lion 10.7.2 bought on AppStore. First I "upgraded from Snow Leopard" and got the "unlock preference panes" problem. I tried everything I found here and on other forum and nothing worked.

    So secondly I restarted from the EFI partition, format the SSD and clean installed Lion again. At the beginning everything were fine, but after a few hours, same problem. I have no more access to unlock any preference pane item. When I click on the lock icon, it asks for my password (I have a admin session) then I click OK and nothing happen, the lock still locked !!!

    - - - - - - - - - - - - - -

    Ok guys, I found something interesting !

    As I can't log on any admin user account, I decided to use the root session. Here is how you can do:

    • If you didn't set up the root account before, 2 ways to do it :
    - 1st way :
    - 2nd way :
    * Open Terminal (via spotlight or /Applications/Utilities/
    * Type : "sudo passwd root"
    * It will ask for your admin user password (your user account) -> "Password:"
    * Then define the root password -> "New password:"
    * Finally, confirm new password -> "Retype new password:"

    • You can test if everything went well by typing
    - "su root" in the terminal windows
    - It will ask for the root password, type the one you previously choose, and a bash command should start ! If so, you root password is set and you can quit the bash command via "exit".

    • When the root account is set, you can go back to your preference pane and set anything. When you'll click on the lock, replace the "Name" field automatically filled by "root" and type the root password in the password field. It should be fine, it worked for me.

    Of course, this is a temporary solution to the preference pane problem, but for now, and after many hours of experimentations, it works !

    Tell me if it works for you too !?
  8. macfan3 macrumors newbie

    May 21, 2012
    root account

    The root account is a good workaround for me! Thanks a lot.

Share This Page