Can't unmount SD-Card through Terminal

Discussion in 'macOS' started by BoxerRobban472, Apr 23, 2017.

  1. BoxerRobban472 macrumors member

    Joined:
    Sep 12, 2013
    Location:
    Gothenburg, Sweden
    #1
    Hi!

    I'm trying to format my SD-Card in order to install OS X onto it. However, it won't unmount during the formatting process, whether in disk utility, terminal using the pseudo command or even in disk utility outside of os on boot... is it the card ? we don't think so because first aid shows nothing wrong with the card itself... Only when we try to format the volume with the eject sign next to it, does it give us error -50... forgive our limited knowledge but this is as far as we understand - it is a brand new Kingston 64gb sd card 90mb transfer rate
     
  2. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #2
    Suggestions:
    - Take the card to a PC and format it, then take it back to the Mac and try again.
    - IF you're using a built-in SD slot, try using a USB card reader instead.

    No promises, just different approaches that might help.
     
  3. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #3
    -50 is (paramErr = -50, /*error in user parameter list*/)

    Don't know what you would be seeing this.

    When I have problems with Disk Utility, TechTool Pro always seems to work.

    Lou
     
  4. BoxerRobban472 thread starter macrumors member

    Joined:
    Sep 12, 2013
    Location:
    Gothenburg, Sweden
    #4
    Sorry for the late reply but I just wanted to say that a(nother) simple restart solved it! Thanks for your help guys! Cheers!
     

Share This Page