Can't update apps from iPhone.

Discussion in 'iPhone' started by kracker, Sep 15, 2008.

  1. kracker macrumors member

    Joined:
    Oct 14, 2007
    #1
    It says I need to update but when I go onto the actual screen to update it says I've already installed. It shows version 1.1 when I need 1.2.

    Are others having this problem?
     

    Attached Files:

  2. icewing macrumors 6502

    Joined:
    Jun 19, 2008
    Location:
    St Louis
    #2
    Wonder if they're having problems with the app store. Toy Bot Diaries shows version 1.1, but the text on the right for the last few days says 1.2 (I'm waiting on a bug fix due to firmware 2.1 so I can play it again :D )

    Anyone else noticing strange versioning problems with any other apps?
     
  3. emt1 macrumors 65816

    Joined:
    Jan 30, 2008
    Location:
    Wisconsin
    #3
    This happened to me today. Plug your iPhone in and go to iTunes. Go to the Applications tab (in the iPhone sync area) and uncheck the offending app. Sync. Recheck the app. Sync.

    Solved the problem for me.
     
  4. FastangV6 macrumors regular

    FastangV6

    Joined:
    Oct 1, 2007
    #4
    I had this problem this morning with the speedtest app. I kept trying every hour or two all day to update with no luck. Tried it again this evening (~12-14 hours later) and it worked fine. No sync since this morning... No idea what fixed it...

    Only difference I can remember is that I was on wifi this evening when it worked and was on 3G all day while it would not work. Might try connecting to wifi and see if that makes a difference? It is the only difference I can think of for mine.
     
  5. periahdark macrumors member

    periahdark

    Joined:
    Aug 18, 2008
    #5
    this also happened in 2.0, dont worry just wait a little while, it just means that the app store hasnt been officially updated, the update was approved but hasnt been released. keep checking back every once and a while and it will say u can download it
     
  6. MacFly123 macrumors 68020

    Joined:
    Dec 25, 2006
    #6
    I have had a bunch of problems with this.

    - It tells me I have updates on my iPhone and I try to update but it says I have to buy the app and then when I click ok it tells me the app is being updated and can't be downloaded.

    - In iTunes it tells me I have updates and I click update all, it gives me a purchase pop up again, I click ok and then it gives me some error.

    P.S. didn't there use to be a button in the updates part of the app store on the iPhone to UPDATE ALL??? I swear there was, and now it is gone and you have to do them all one at a time........ ANNOYING!!! :(
     
  7. loskickking23 macrumors 6502a

    Joined:
    Jun 13, 2008
    #7
    This happened to me last night on 3g.When I changed over to edge it was fine .This went on for about 2 hours yesterday.
     
  8. z062007 macrumors member

    z062007

    Joined:
    Mar 28, 2008
    Location:
    Detroit, Michigan
    #8
    I had problems trying to update Super Monkey Ball and Aurora Feint. this was a while back and before the 2.1 release. this is what i did:

    I will warn you that there is a change that you may lose data related to the apps doing the steps below. I take no responsibility for any lose any data. I had to restart my game in Monkey Ball and lost all high scores. Back up any important data before continuing.

    1) Delete the app from your computer
    2) Sync your iPhone so that the app will be deleted from there.
    3) Download the Apps from the app store not using the update method. pretend that you are buying the app for the first time.
    4) Sync your iPhone again and the apps will be installed.

    Hope this helps. :D
     
  9. kracker thread starter macrumors member

    Joined:
    Oct 14, 2007
    #9
    Still can't update on the iPhone but I just did through iTunes.
     
  10. Cynicalone macrumors 68040

    Cynicalone

    Joined:
    Jul 9, 2008
    Location:
    Okie land
    #10
    I've had this happen before, I just waited a few hours after the update was said to be available and then was able to d/l to the phone.

    I usually use iTunes, just seems easier imo. But on the road sometimes you don't have a choice.
     

Share This Page