Can't update device isn't eligible for the requested build. Need help ASAP.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by JJBro1, Jul 5, 2011.

  1. JJBro1 macrumors regular

    Joined:
    May 17, 2009
    #1
    I'm trying to update my roommates iphone 4 from 4.3 to 4.3.3 and I'm gettings this error that says I can't update the device because it's not eligible for the requested build. What does this mean and what do I do to fix it?
     
  2. FeaRThiS macrumors 6502

    Joined:
    Mar 25, 2011
    #2
    I know this doesnt help much but I'm sure this is the same message you get when trying to load a beta os onto a device that hasnt had its udid added to a dev account.
     
  3. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #3
    Probably something in the hosts file or a remnant of a previous jailbreak.
     

Share This Page