Can't update from Mac App Store

Discussion in 'OS X Mavericks (10.9)' started by pencilcheck, Oct 22, 2013.

  1. pencilcheck macrumors member

    Joined:
    Sep 2, 2010
    #1
    For some reason after an update, now I can't update in Mac App Store.

    It just shows an empty white block at the top. I tried relogging, restarting, none worked.

    Is there a solution to this problem?
     

    Attached Files:

  2. robvas macrumors 68020

    Joined:
    Mar 29, 2009
    Location:
    USA
    #2
    I have the same problem. And the SSD firmware update and the Battery SMC update keep installing/re-installing. I think I am going to do a fresh install of Mavericks
     
  3. pencilcheck thread starter macrumors member

    Joined:
    Sep 2, 2010
    #3
    It's weird that I can still download and update apps manually from their respective store page and purchase tab.
     
  4. kfscoll macrumors 65816

    kfscoll

    Joined:
    Nov 3, 2009
    #4
    I can do that too, but the one update it tells me I need must be some sort of system update because I can't tell by looking at the "Purchases" list what needs updated. This is very frustrating and I'd really like to avoid doing a full Mavericks reinstall.
     
  5. AppleTalker macrumors member

    Joined:
    Feb 22, 2013
    #5
    I was able to download everything. The only problem i have is 3 iMovie Apps, one of them is the updated version, and it works and everything, the only thing the icon isn't updated and it's still "downloading": http://gyazo.com/c72653e57e66bc8bacd37a389fe9d052

    ^ But no movement. I'm think just deleting the 3 applications and re-downloading the updated iMovie form the App Store will work? :(
     
  6. pencilcheck thread starter macrumors member

    Joined:
    Sep 2, 2010
    #6
    Still cannot see the updates..... someone help
     
  7. Threaded Bolt macrumors newbie

    Joined:
    Oct 16, 2013
    #7
    if you have used the 10.9 developer version check if the Apple ID from the developer version matches your Apple store ID. Log into the store with the ID from the developer version, the update should show up.
     
  8. Crazy Badger, Oct 23, 2013
    Last edited: Oct 23, 2013

    Crazy Badger macrumors 65816

    Crazy Badger

    Joined:
    Apr 1, 2008
    Location:
    Scotland
    #8
    Similar problem, but not sure if it's related the the Apple ID as I can see updates on my MBA but not on the iMac, and both are using the same Apple ID and version of 10.9 GM

    Update - Just downloaded and ran the installer again, which has fixed the problem!
     
  9. pencilcheck thread starter macrumors member

    Joined:
    Sep 2, 2010
    #9
    What do you mean by the developer version? I installed the GM, and I logged in everything with my Apple ID, but I noticed some weird thing that might be related to what you said, later I got a update notification and when I tried to click on it, it wants me to enter Apple ID password. That's normal it seems, but the weird thing is that the id pre filled is not the AppleID I logged in....

    I wonder if that's the cause for me to not be able to see updates in the App Store, if so how do I make sure that the Update is displaying updates for my AppleID account?

    I said I have relogged (from Apple Store menu Store) and restarted Mavericks, but still the same....
     
  10. pencilcheck thread starter macrumors member

    Joined:
    Sep 2, 2010
  11. kfscoll macrumors 65816

    kfscoll

    Joined:
    Nov 3, 2009
    #11
  12. lehman310 macrumors member

    Joined:
    Mar 10, 2009
    #12
    That method did not work for me either. I am not able to update from GM1 to the consumer version.
     
  13. pmz macrumors 68000

    Joined:
    Nov 18, 2009
    Location:
    NJ
    #13
    Same problem here, would love to hear of a fix. Currently can't even redownload Mavericks to make a bootable usb.
     
  14. jhfenton macrumors 6502a

    jhfenton

    Joined:
    Dec 11, 2012
    Location:
    Norwood, Ohio
    #14
    From another thread:

    This fixed my problem downloading the release version from the first GM.

    John
     

Share This Page