can't update my iPhoto 9.1.5 to 9.2

Discussion in 'Mac OS X Lion (10.7)' started by wkl5532, Oct 13, 2011.

  1. wkl5532 macrumors newbie

    Joined:
    Jan 3, 2011
    #1
    Help! After I updated to Lion 10.7.2 I can't update my iPhoto, I tried the software update and I tried the iCloud preference, won't work, it said my software are up to date. I even downloaded the package from apple.com but it said I have to go to the app store to update, WTF to that:confused:
     
  2. blue07 macrumors newbie

    Joined:
    Sep 14, 2008
    #2
    same here

    I have the exact same problem; I don't wan't to pay $15 from the mac app store to upgrade...any ideas?
     
  3. Mess macrumors 6502

    Mess

    Joined:
    Nov 27, 2008
    Location:
    Newcastle Upon Tyne, UK
    #3
    have you tried the check for update from within the program its self? It could be apples servers too...
     
  4. blue07 macrumors newbie

    Joined:
    Sep 14, 2008
    #4
    I tried software update one more time and I received the update option - all OK now.
     
  5. wkl5532 thread starter macrumors newbie

    Joined:
    Jan 3, 2011
    #5
    I've tried software update for like 20 times, I tried restart my macbook air, but I still can't get the update notification.
    Guys, I can download the 9.2 update file of 300m from apple support.com but I just DO NOT UNDERSTAND why I CAN NOT INSTALL IT ! If I have to install it from the app store as it told me to, why do apple have this link to download it from apple support? IT DOES NOT MAKE ANY SENSE!!!!!!!!:mad::mad::mad::mad::mad::mad::mad::mad::mad:
     
  6. Tbone999 macrumors member

    Joined:
    Jun 18, 2009
    #6
    Argggg.

    Same problem. App Store says no update needed or available. iCloud pref panel says iPhoto needs to be updated, but when I hit the upgrade button, app store says no.

    I manually downloaded 9.2. from Apple's support site and guess what? When I run the installer it says "This application can only be updated from the app store."

    Software Update says no updates needed or available, and I've checked umpteen times. very frustrating -- wanted to try out photo stream.

    ----------

    Can't update iPhoto from within program itself.
     
  7. wkl5532 thread starter macrumors newbie

    Joined:
    Jan 3, 2011
    #7
    Any solutions guys? I'm just pissed off cause i want to try photo stream
     
  8. h5none macrumors newbie

    Joined:
    Oct 13, 2011
    Location:
    England
    #8
    iPhoto update --- not!!!

    Tried all day to update iPhoto thinking it may be be busy servers,still no joy,software update on my iMac all up to date apparently,still waiting for iCloud for a fix to Photo Stream.
    looks cool can't wait to try it :)
     
  9. waynep macrumors 6502

    Joined:
    Dec 31, 2009
    #9
    It depends on how you installed iPhoto. I installed iPhoto from a DVD that was included with my MBP, also came with Snow Leopard. I bought Lion from the App store and upgraded to 10.7.2. After that was done, I ran the Software Update from the Apple menu and it upgrades iPhoto for me. My iPhoto upgrade did NOT come from the App store.
     
  10. Tbone999, Oct 13, 2011
    Last edited: Oct 13, 2011

    Tbone999 macrumors member

    Joined:
    Jun 18, 2009
    #10
    I had iPhoto on my machine when I bought it -- either late 2009 or early 2010 -- and then I upgraded it to iPhoto 2011 (9.1) through the app store. No upgrade to 9.2 through the app store or through software update. Ack.
     
  11. Madd the Sane macrumors 6502

    Madd the Sane

    Joined:
    Nov 8, 2010
    Location:
    Utah
    #11
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    Apple's servers got hammered on Wednesday. Try using Software Update if you installed from a DVD, or the App Store if you got it there, now. If the problem persists, contact Apple Support.
     
  12. Steve's Barber macrumors 6502a

    Joined:
    Jul 5, 2011
    #12
    This worked for me.
     
  13. macstickmac macrumors newbie

    Joined:
    Aug 31, 2008
    #13
    Try this

    So i had the problem too.

    iPhoto 9.1.5 Unable to update via:

    Software update
    Update option in iPhoto
    Download the update 9.2 form Apple.com

    All above failed.

    My iPhoto.app is in a sub-folder in my applications folder /Applications/iLife/iPhoto.app

    I moved iPhoto back in to the application folder, ran update and it showed up... all working for me, hope it does for you too!
     
  14. Tbone999 macrumors member

    Joined:
    Jun 18, 2009
    #14
    Well, that's not my problem. I have iPhoto sitting there right in Applications.

    I spent half an hour on the phone with tech support. I went to "purchases" in the App STore and it clearly says I purchased iPhoto '11 on February 28, 2011, and it has an "update" button. If you hit that, it says my purchase was for another account! I DON'T HAVE another account. I am still waiting on Apple Support to fix this -- they had me initiate an email to the iTunes (other purchases or issues) department.

    Meanwhile if you have 3idx in your pref pane, you have to remove it (and the 3idx file in Application Support) for Photostream to work. The tech support guy had me uninstall it. In the event that this issue gets resolved, I won't have a problem with that. :)
     
  15. Tbone999 macrumors member

    Joined:
    Jun 18, 2009
    #15
    It appears we have a solution.

    Per apple: Greetings from Austin, Texas! My name is Ashley with iTunes/Mac App Store support. I'll be assisting you today. I hope this email finds you well! I understand that you are having some trouble updating iPhoto '11 on your computer. I'm sorry for this inconvenience, I know that this must be frustrating, and we greatly appreciate your patience with this matter.

    Thank you for sending those screenshots, they were very helpful! I've checked your account, and I was able to locate your purchase of iPhoto '11 on your account "XXX". I'm not sure why you're receiving an error message saying that you purchased this application from a different account.

    What I need you to do is locate iPhoto in your Applications Folder. After locating the app, drag it into the Trash. Once this application is deleted, we can redownload it to your computer.

    You can redownload apps you have purchased from the Mac App Store without incurring additional charges.


    It worked!
     

    Attached Files:

  16. Sc00tr macrumors regular

    Joined:
    May 28, 2011
    #16
    For installing off of CD I had posted about it here with my solution.
    http://forums.macrumors.com/showthread.php?t=1251784&highlight=

    I cant remember if I tried this or not.
     
  17. NachoViglione macrumors newbie

    Joined:
    Oct 15, 2011
    #17


    Thank you Tbone999 for your posting. I had the same problem with the difference that I did not buy the application, it came bundled into my brand new iMac with preinstalled Lion. I put the app in the trash, went into App Store, looked for iPhoto, the button said "Accept", I clicked, asked my Apple ID password and I got the application on the download list at no cost, the other iLife apps are also displayed on that list, but they appear as they are up to date. Now it's being downloaded, it's a 762,06 MB file. This is solved, thanks to Ashley!
    Best,

    Nacho
     
  18. Tbone999 macrumors member

    Joined:
    Jun 18, 2009
    #18
    Glad to hear it worked for you, Nacho! There seems to be some App Store/authentication bug. I just thank god Ashley knew the fix.

    I'm tired of some of these customer service reps from some companies (not mentioning names *cough* EA *cough*) that just don't care that you bought the application and simply won't accept responsibility for a bug that requires you to reauthenticate (read: buy it again) when you shouldn't have to.

    So far, Apple, you're golden.
     
  19. danamania macrumors member

    Joined:
    Jul 27, 2004
    #19
    I just found this thread after seeing the iCloud prefpane noted that I needed to upgrade in order to turn photostreaming on, on the Mac itself - but still no software updates appeared. Nothing through the app store, or software update, or checking for updates within iPhoto itself.

    It wasn't until I turned on the iCloud guff with the same account on the iPhone itself that software update suddenly showed 9.2.

    I don't know if it's a coincidence; it seems a strange restriction for 9.2 on Apple's part if it's not, but this late after the release of 9.2 I'd have expected it to be picked up beforehand.
     
  20. RatHat macrumors member

    Joined:
    Jun 29, 2011
    #20
    That worked for me! Thanks.
     

Share This Page