Can't update to Beta 2.

Discussion in 'OS X El Capitan (10.11)' started by gabriellefunk, Jun 25, 2015.

  1. gabriellefunk macrumors member

    Joined:
    Jun 10, 2015
    #1
    It shows that I have an update, but every time I click on it the App Store is blank. I can't download apps either. Is there a fix to this? I would really like Beta 2.
     
  2. tywebb13, Jun 25, 2015
    Last edited: Jul 28, 2015
  3. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #3
    Actually, though, Safari won't let me access the Developer's website. So how do I download it manually? Safari has been messed up ever since I got DB1.
     
  4. tywebb13, Jun 25, 2015
    Last edited: Jul 28, 2015
  5. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #5
    "Safari can't open the page "https://developer.apple.com" because Safari can't establish a secure connection to the server "developer.apple.com". This happens more often than not.
     
  6. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #6
    I don't have any other browser downloaded on my Mac and it won't let me download any others, because of the same error that constantly shows up. I'm lost.
     
  7. jozeppy26, Jun 25, 2015
    Last edited: Jun 25, 2015

    jozeppy26 macrumors 6502

    jozeppy26

    Joined:
    Jul 8, 2008
    Location:
    St. Louis
    #7
    Google will help you find direct download links.
     
  8. tywebb13, Jun 25, 2015
    Last edited: Jul 28, 2015
  9. tywebb13, Jun 25, 2015
    Last edited: Jul 28, 2015
  10. jozeppy26 macrumors 6502

    jozeppy26

    Joined:
    Jul 8, 2008
    Location:
    St. Louis
    #10
    Yeah but there are fairly reputable sources for accessing beta iOS and OSX releases.
     
  11. tywebb13, Jun 25, 2015
    Last edited: Jul 28, 2015
  12. tywebb13, Jun 26, 2015
    Last edited: Jul 28, 2015
  13. SG- macrumors regular

    SG-

    Joined:
    Jun 8, 2015
    #13
    it sounds like something is broken on your Mac preventing SSL connections to work. try getting Firefox or Chrome and seeing if you can download it.
     
  14. adrianlondon macrumors 6502

    Joined:
    Nov 28, 2013
    Location:
    Switzerland
    #14
    If your browser doesn't work, and app store doesn't work, I'd suggest restoring and starting again as being the safest way.
     
  15. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #15
    Sounds like something is going on with your SSL, I have no issues with the developer.apple.com link though the computer I'm on currently is running Mavericks.

    Back up your data and try a reinstall of DP1, preferably a clean install.
     
  16. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #16
    I put Firefox and Chrome on a flash drive and put them on my MacBook Pro and the websites still aren't working. "This connection is untrusted," etc. error messages.
     
  17. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #17
    To everyone that has been so kind as to help me out in this thread:

    I've got it all figured out! Finally. It feels like it took forever (and it practically did), but what I did was this-
    I updated to DP2 via Terminal by using sudo softwareupdate -iva. It downloaded and then installed, and all I had to do was restart my MacBook afterwards. Thank goodness.

    Then, my Safari was still not working properly, so I put my AdwareMedic and Avast Mac Security in the Trash, emptied it, and then restarted and everything is working flawlessly now. Even my Mail (which I was also having issues with).

    Again, thank you everyone!
     
  18. SG- macrumors regular

    SG-

    Joined:
    Jun 8, 2015
    #18
    you should never install that stuff, especially on a dev release system (but in general don't bother with antivirus on OSX, it will cause more trouble).
     
  19. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #19
    I installed it for a quick second because I got malware on my Mac from streaming a third-party movie and forgot to take it off afterwards. It won't be back on though!
     

Share This Page