Can't update to iOS 5 - help!

Discussion in 'iOS 5 and earlier' started by Cookiesandmilk, Oct 15, 2011.

  1. Cookiesandmilk macrumors newbie

    Joined:
    Oct 15, 2011
    #1
    My iPhone 4 is version 4.3.3 and I already updated my iTunes to 10.5. However, I cannot update or restore it!! Help?

    It keeps saying that the device is not eligible for the requested build! :(
     
  2. aleric macrumors newbie

    Joined:
    Aug 26, 2009
    #2
  3. slsanity macrumors newbie

    Joined:
    Mar 18, 2008
    Location:
    Chengdu, China
    #3
    If you've ever used TinyUmbrella, open it, uncheck "Set Hosts to Cydia on Exit".

    Or go to edit /etc/hosts and remove the apple lines.
     
  4. Cookiesandmilk thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #4
    Thank you for everything! :D
    I was really worried just now ><
    For some reason my iTunes just refuses to restore/update no matter what I do. I tried putting my phone into recovery mode - for those out there whose mac is unable to restore/update your device, chances are it can't restore your device in recovery mode as well! Best shot would be to use a windows laptop/pc, download iOS 5 then connect back to your mac :D (remember to backup on your mac first! when you click update on your mac they will backup your phone first, even if you can't update to iOS 5 on your mac.) then ta-da :D
     

Share This Page