Cant update to ios7 beta 2 or 3

Discussion in 'iOS 7' started by andyxdz, Jul 12, 2013.

  1. andyxdz, Jul 12, 2013
    Last edited: Jul 12, 2013

    andyxdz macrumors newbie

    Joined:
    Jul 18, 2012
    #1
    So i downloaded ios7


    It works fine but when i press "restore" or "check for update" in itunes to download the beta2 or 3 software, itunes says "could not update because firmware file is not compatible." Please help if you can, Thanks.
     
  2. Decimotox macrumors 6502a

    Joined:
    Jul 8, 2013
    #2
    You probably downloaded the wrong version of iOS for your phone/device. Make sure you check your model number on the back of your device and download the correct firmware for it.
     
  3. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #3
    Are you running beta-1 and trying to use iTunes to automatically download and install betas-2 and 3?
    That's not how it works.
    All betas need to be installed either OTA or by manually downloading them and then manually selecting them from within iTunes.
    And if you are running beta-1 then you'd better revert to iOS6 before the beta expires.
     
  4. andyxdz thread starter macrumors newbie

    Joined:
    Jul 18, 2012
    #4
    i am using the right firmware on beta1. I am pressing alt and selecting the beta2 update but it say firmware isnt compatible. Should i revert to ios6 and download beta3 only?
     
  5. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #5
    Then it sounds like you downloaded the correct beta-1 but the incorrect beta-2.

    But if you do have beta-1 you should be able to update to the next beta right on the device over the air.
    Settings -- General -- Software Update.
     
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    Is the beta 2 file the right one for the device you have? What about doing the same thing with beta 3 file (since you should be able to just go directly to that from beta 1), making sure it's the right file for the device you have?
     
  7. andyxdz thread starter macrumors newbie

    Joined:
    Jul 18, 2012
    #7
    it may have updated to beta 3 without me noticing, how can i tell exactly which update i am on. iTunes says my phone is just on ios 7.0
     
  8. Defender2010 macrumors 68030

    Defender2010

    Joined:
    Jun 6, 2010
    Location:
    England
    #8
    If you were using the wrong firmware for beta 1 you wouldn't have been able to install it in the first place. If iTunes says the file is not compatible then it is either a) the wrong file or b) corrupted - redownload the file. If it still says it is not compatible - it is indeed the wrong file.
     
  9. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #9
    See if you notice any of the beta 3 changes: http://www.macrumors.com/2013/07/08...-animation-thicker-fonts-safari-improvements/ A better way would really be just to check the (build) version on the phone and compare that against the one that is for beta 3.
     
  10. andyxdz thread starter macrumors newbie

    Joined:
    Jul 18, 2012
    #10
    file must have been corrupted reinstalled and they worked. Thank you :)
     

Share This Page